Bug 826815 - MSG: systemd-analyze --user should give a nicer error message when systemd is not running for the user
MSG: systemd-analyze --user should give a nicer error message when systemd is...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
abrt_hash:d1c1acbf8e17b05363162a84e9a...
:
: 863585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 23:32 EDT by Jeff Raber
Modified: 2013-04-12 18:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-12 18:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Raber 2012-05-30 23:32:40 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/systemd-analyze --user plot
comment:        Ran the command as reported.  I didn't know what to expect, but I didn't expect a crash.
executable:     /usr/bin/systemd-analyze
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 30 May 2012 10:06:06 PM CDT
uid:            1000
username:       jeff

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /bin/false exited with status 1
:
:Traceback (most recent call last):
:  File "/usr/bin/systemd-analyze", line 309, in <module>
:    verb.get(args[0], unknown_verb)()
:  File "/usr/bin/systemd-analyze", line 125, in plot
:    initrd_time, start_time, finish_time = acquire_start_time()
:  File "/usr/bin/systemd-analyze", line 32, in acquire_start_time
:    properties = dbus.Interface(bus.get_object('org.freedesktop.systemd1', '/org/freedesktop/systemd1'), 'org.freedesktop.DBus.Properties')
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 244, in get_object
:    follow_name_owner_changes=follow_name_owner_changes)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 241, in __init__
:    self._named_service = conn.activate_name_owner(bus_name)
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
:    self.start_service_by_name(bus_name)
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
:    'su', (bus_name, flags)))
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /bin/false exited with status 1
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x7f42313035f0>
:args: ('org.freedesktop.systemd1', 0)
:utf8_strings: False
:bus_name: 'org.freedesktop.DBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/freedesktop/DBus'
:timeout: -1.0
:signature: 'su'
:dbus_interface: 'org.freedesktop.DBus'
:message: <dbus.lowlevel.MethodCallMessage object at 0x7f4237831150>
:method: 'StartServiceByName'
Comment 1 Elad Alfassa 2012-07-29 10:37:33 EDT
Started systmed-analyze --user

Package: systemd-analyze-44-17.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Lennart Poettering 2013-01-14 13:40:04 EST
*** Bug 863585 has been marked as a duplicate of this bug. ***
Comment 3 Matt Gates 2013-01-15 13:35:14 EST
systemd-analyze --user

Package: systemd-analyze-195-15.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 4 Lennart Poettering 2013-03-07 11:31:57 EST
Fixed in git. (since we have an implementation in C now, of this tool)
Comment 5 Michal Schmidt 2013-04-12 18:51:28 EDT
The fix is in F18 (at least in the version that's currently in updates-testing).
At this point not much effort will be spent on systemd in F17. Only fixes for severe bugs can be expected.

Note You need to log in before you can comment on or make changes to this bug.