Bug 82682 - Konqueror crash when closing a window
Konqueror crash when closing a window
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-24 15:55 EST by Mario A. Vazquez
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-04 18:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario A. Vazquez 2003-01-24 15:55:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030121

Description of problem:
Konqueror crash when closing a window.  Sometimes it also close additional
konqueror windows that were previously open.  Here I include the backtrace at
the moment of the crash.

---------------
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1092486720 (LWP 24492)]
0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x4063040d in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x40c15cb7 in QGDict::unlink_ascii(char const*, void*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#4  0x40c16164 in QGDict::take_ascii(char const*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#5  0x403f1141 in KActionCollection::_take(KAction*) ()
   from /usr/lib/libkdeui.so.4
#6  0x403f12a6 in KActionCollection::take(KAction*) ()
   from /usr/lib/libkdeui.so.4
#7  0x403e0b30 in KAction::~KAction() () from /usr/lib/libkdeui.so.4
#8  0x409ad232 in QObject::~QObject() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#9  0x403f0a97 in KActionCollection::~KActionCollection() ()
   from /usr/lib/libkdeui.so.4
#10 0x409de778 in QWidget::~QWidget() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#11 0x40a88dff in QMainWindow::~QMainWindow() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#12 0x40439c0e in KMainWindow::~KMainWindow() () from /usr/lib/libkdeui.so.4
#13 0x400503c8 in KParts::MainWindow::~MainWindow() ()
   from /usr/lib/libkparts.so.2
#14 0x4129be81 in KonqMainWindow::~KonqMainWindow() ()
   from /usr/lib/konqueror.so
#15 0x409adcb3 in QObject::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#16 0x409e3f3c in QWidget::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#17 0x40a8aa92 in QMainWindow::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#18 0x40951ed4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#19 0x40951ac9 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#20 0x405c41e9 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#21 0x40952c6a in QApplication::sendPostedEvents(QObject*, int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#22 0x40965c89 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#23 0x40965b48 in QEventLoop::exec() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#24 0x40952101 in QApplication::exec() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#25 0x412973f7 in main () from /usr/lib/konqueror.so
#26 0x0804ca81 in strcpy ()
#27 0x0804d73b in strcpy ()
#28 0x0804dbec in strcpy ()
#29 0x0804e8f9 in strcpy ()
#30 0x420154a0 in __libc_start_main () from /lib/tls/libc.so.6
-----------------------


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open any konqueror window (browser or local dir)
2. Click on the close button


Actual Results:  Konqueror crash and show it�s error screen giving the option of
backtrace.

Expected Results:  The window should close without problem.

Additional info:

Haven�t tested, but apparently is from updating to those version of libs from
rawhide 20030123

kdebase-3.1-0.14.i386.rpm
glibc-common-2.3.1-38
glibc-devel-2.3.1-38
glibc-utils-2.3.1-38
glibc-2.3.1-38
glibc-profile-2.3.1-38
Comment 1 Ngo Than 2003-02-04 18:47:59 EST
it works for me with kdelibs-3.1-2/kdebase-3.1-2.

Note You need to log in before you can comment on or make changes to this bug.