Bug 826829 - Software error when doing anywords or allwords search that starts or ends with a space
Software error when doing anywords or allwords search that starts or ends wit...
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 01:20 EDT by Qin Guan
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.2.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 19:39:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
20120531-bugzilla-query-error.txt (3.50 KB, text/plain)
2012-05-31 01:22 EDT, Qin Guan
no flags Details

  None (edit)
Description Qin Guan 2012-05-31 01:20:51 EDT
Description of problem:

Found this error when query bugs with space in front of the string in the comment of the detailed bug information.

Please stand by ...
Software error:

DBD::mysql::st execute failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')

Version-Release number of selected component (if applicable):
4.2

How reproducible:
100%

Steps to Reproduce:
1. Open the Advanced Search page
2. Select any Product and Component, such as 
 Product : Red Hat Enterprise Linux 5
 Component: kernel-xen
3. Input a string into the Comment Input box with a space in front of, like " vcpu" (without quotes), like below: 
 Detailed Bug Information 
 Comment:  contains all of the strings " vcpu"(without quotes)
  
Actual results:
Software error

Expected results:
No Software error

Additional info:
Comment 1 Qin Guan 2012-05-31 01:22:08 EDT
Created attachment 587939 [details]
20120531-bugzilla-query-error.txt
Comment 2 Simon Green 2012-05-31 02:31:20 EDT
Reason for hotfix: This one is going upstream, but I want to provide a patch for them too.
Comment 4 Simon Green 2012-05-31 09:03:10 EDT
Filed upstream at https://bugzilla.mozilla.org/show_bug.cgi?id=760075

Will be in our 4.2.1-2 release regardless.

  -- simon
Comment 5 Simon Green 2012-06-06 01:55:42 EDT
Upstream rejected our changes because it caused an unintended side effect. We will fix our code to match the change upstream too.

  -- simon
Comment 6 Simon Green 2012-06-11 19:39:38 EDT
The upstream change was approved for Bugzilla 4.2, so we will inherit it with the next release.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.