Bug 826845 - The attribute "feature.read-only" is not consistent in output.
The attribute "feature.read-only" is not consistent in output.
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 02:42 EDT by Gowrishankar Rajaiyan
Modified: 2013-12-18 19:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 03:32:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-05-31 02:42:43 EDT
Description of problem:


Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa45-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. gluster volume set test2 read-only off

2. gluster volume info test2
 
Volume Name: test2
Type: Distribute
Volume ID: a96e3565-3a01-4b6e-b2ea-3e14bf564738
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: dhcp201-214.englab.pnq.redhat.com:/export/shanks/shanks2
Options Reconfigured:
feature.read-only: off
[root@dhcp201-221 ~]# 
  
Actual results:
Out put has "feature.read-only: off"


Expected results: The parameter "feature.read-only" should be "Read only: off" for consistency. 


Additional info:
Comment 2 Amar Tumballi 2012-05-31 03:32:38 EDT
[root@supernova Gluster_Brand]# gluster volume set test quick-read off
Set volume successful
[root@supernova Gluster_Brand]# gluster volume info test
 
Volume Name: test
Type: Distribute
Volume ID: 63796d88-40a1-473d-bcbf-1c3e25957342
Status: Stopped
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: supernova:/tmp/export/c6
Options Reconfigured:
performance.quick-read: off



Note that i gave 'quick-read' off, but it expanded to 'performance.quick-read: off' on the output. That is because the actual key to be used is 'performance.quick-read' and because we have a trie implemented to assume some out wanted the same key. For example, one can do 'gluster v i' to get 'gluster volume info' output.

One can find the list of all the supported keys by 'gluster volume set help'.

Note You need to log in before you can comment on or make changes to this bug.