This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 826860 - Help rootnoverify info show in grub when edit kernel command line if install RHEV-H via livecd
Help rootnoverify info show in grub when edit kernel command line if install ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression
Depends On:
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-05-31 03:18 EDT by shaochen
Modified: 2016-04-26 10:19 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-11.el6
Doc Type: Bug Fix
Doc Text:
Previously, the default Hypervisor kernel boot options included a missing splashscreen option in grub. Without that option, when attempting to edit the kernel command line the grub console placed help text corresponding to the characters typed, rather than the characters themselves. Now, the splashscreen option is only added if a splashscreen file is present.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:35:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shaochen 2012-05-31 03:18:56 EDT
Description of problem:
Help rootnoverify info show in grub when edit kernel command line if install RHEV-H via livecd.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6

How reproducible:
100%

Steps to Reproduce:
1. Make livecd to usb via command
"rhevh-iso-to-disk --format rhevh-6.3-20120523.1.el6.iso /dev/sdb"
2. Boot from usb and install RHEV-H.
3. Reboot RHEV-H.
4. Enter grub menu, press "e" key to edit kernel command line.
5. Input "rescue" or hold down any key always.
  
Actual results:
1. Help rootnoverify info show in grub when edit kernel command line.
2. This issue only occurs when install RHEV-H via licecd, no such issue if install RHEV-H via PXE.
3. For enter "rescue" mode, you need press "c" key in grub for a command-line, and press "Esc" key return to grub, and then press "e" key can edit kernel command line correctly.

Help rootnoverify info:
 [HDBIAS]]
    Similar to `root', but don't attempt to mount the partition. This
    is useful for when an OS is outside of the area of the disk that
    GRUB can read, but setting the correct root device is still
    desired. Note that the items mentioned in `root' which derived
    from attempting the mount will NOT work correctly. 

Expected results:
Input information can show correctly.

Additional info:

No such issue in rhevh-6.3-20120509.1.el6, so it is a regression bug.
Comment 2 Mike Burns 2012-06-01 11:25:30 EDT
Let me see if I can summarize the problem differently

Install rhevh
reboot
drop to grub menu
highlight kernel line
try to edit the kernel line by pressing 'e'

--> get a dump of output with info on rootnoverify


Is this accurate?

Does this happen on 20120531.0?
Comment 4 shaochen 2012-06-03 21:18:54 EDT
(In reply to comment #2)
> Let me see if I can summarize the problem differently
> 
> Install rhevh
> reboot
> drop to grub menu
> highlight kernel line
> try to edit the kernel line by pressing 'e'
> 
> --> get a dump of output with info on rootnoverify
> 
> 
> Is this accurate?

The steps are correct, but need install rhevh via USB. 
No such issue if install rhevh via PXE.

> Does this happen on 20120531.0?

It can reproduced on rhev-hypervisor6-6.3-20120531.0.el6.
Comment 18 Tim Hildred 2013-02-12 01:15:42 EST
Joey, can you please review my doc_text, and edit if necessary?
Comment 21 errata-xmlrpc 2013-02-28 11:35:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.