Bug 826882 - g++44 code crashes when compiled with -O2 -fPIC and -O3 -fPIC
g++44 code crashes when compiled with -O2 -fPIC and -O3 -fPIC
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc (Show other bugs)
6.4
All Linux
high Severity high
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On: 556962
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 04:05 EDT by Jakub Jelinek
Modified: 2013-02-21 05:26 EST (History)
6 users (show)

See Also:
Fixed In Version: gcc-4.4.7-2.el6
Doc Type: Bug Fix
Doc Text:
Previously, the C++ compiler was incorrectly optimizing away certain checks, if we were assigning an integer value, bigger than the last element of an enum, to that enum using static_cast. This has been fixed so that now the compiler does not removes such checks.
Story Points: ---
Clone Of: 556962
Environment:
Last Closed: 2013-02-21 05:26:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 errata-xmlrpc 2013-02-21 05:26:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0420.html

Note You need to log in before you can comment on or make changes to this bug.