Bug 826905 - SELinux is preventing /usr/sbin/sshd from 'name_bind' accesses on the tcp_socket .
SELinux is preventing /usr/sbin/sshd from 'name_bind' accesses on the tcp_soc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:39395824d3ce675fbf6d1bc27a0...
:
: 1043575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 04:46 EDT by Keith Dickmann
Modified: 2014-01-07 06:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 08:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Dickmann 2012-05-31 04:46:27 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Thu 31 May 2012 06:43:43 PM EST

description:
:SELinux is preventing /usr/sbin/sshd from 'name_bind' accesses on the tcp_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that sshd should be allowed name_bind access on the  tcp_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sshd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sshd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:http_port_t:s0
:Target Objects                 [ tcp_socket ]
:Source                        sshd
:Source Path                   /usr/sbin/sshd
:Port                          443
:Host                          (removed)
:Source RPM Packages           openssh-server-5.9p1-22.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1
:                              SMP Mon May 21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Thu 31 May 2012 06:42:40 PM EST
:Last Seen                     Thu 31 May 2012 06:42:40 PM EST
:Local ID                      062cb11d-b0aa-4e06-bc20-3fef5936e191
:
:Raw Audit Messages
:type=AVC msg=audit(1338453760.152:31): avc:  denied  { name_bind } for  pid=988 comm="sshd" src=443 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:http_port_t:s0 tclass=tcp_socket
:
:
:type=SYSCALL msg=audit(1338453760.152:31): arch=x86_64 syscall=bind success=yes exit=0 a0=3 a1=7f974b1c3a30 a2=10 a3=7fffc43c56e8 items=0 ppid=1 pid=988 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sshd exe=/usr/sbin/sshd subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: sshd,sshd_t,http_port_t,tcp_socket,name_bind
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-31 08:06:25 EDT
You changed the default port which is used by sshd. So you need to change a port or allow it using local policy as sealert tell you.
Comment 2 Miroslav Grepl 2014-01-07 06:34:59 EST
*** Bug 1043575 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.