Bug 826931 - [RHEVM] [backend] hot plug NIC needs to be blocked in all VM states except for UP/DOWN/powering UP
[RHEVM] [backend] hot plug NIC needs to be blocked in all VM states except fo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Muli Salem
Martin Pavlik
network
: TestBlocker
Depends On:
Blocks: 581266 833637 835390 835392
  Show dependency treegraph
 
Reported: 2012-05-31 05:19 EDT by Martin Pavlik
Modified: 2016-02-10 14:52 EST (History)
8 users (show)

See Also:
Fixed In Version: si15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 830816 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (25.20 KB, application/x-gzip)
2012-05-31 05:19 EDT, Martin Pavlik
no flags Details
NIC activated (143.97 KB, image/png)
2012-05-31 05:21 EDT, Martin Pavlik
no flags Details
nic deactivated (143.89 KB, image/png)
2012-05-31 05:22 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-31 05:19:16 EDT
Created attachment 588007 [details]
vdsm.log + engine.log

Description of problem:
it is possible to hot plug/unplug NIC from VM during VM powering up

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
have windows 7 machine with one NIC
1. start the VM
2. quickly click on Network Interfaces -> Activate/Deactivate

  
Actual results:
HotPlug Unplug is working when VM is powering UP

Expected results:
HotPlug Unplug should be working only when VM is UP/DOWN

Additional info:
Comment 1 Martin Pavlik 2012-05-31 05:21:51 EDT
Created attachment 588010 [details]
NIC activated
Comment 2 Martin Pavlik 2012-05-31 05:22:13 EDT
Created attachment 588011 [details]
nic deactivated
Comment 3 Martin Pavlik 2012-05-31 06:46:19 EDT
It is also possible to Activa/Deactivate the nic during VM Powering Down phase
Comment 4 Martin Pavlik 2012-05-31 07:24:01 EDT
It is also possible to Activa/Deactivate the nic during migration

This should be blocked
Comment 5 Martin Pavlik 2012-05-31 10:51:54 EDT
It is also possible to Activa/Deactivate the nic during suspend

This should be blocked
Comment 6 Itamar Heim 2012-06-21 08:46:18 EDT
what's the problem with hotplug/unplug during power up?
Comment 7 Martin Pavlik 2012-06-21 09:30:09 EDT
To be honest, I do not know the reason behind this. I just followed test cases which are mentioned in this bug and they explicitly say it should not be possible, so I reported a bug.
Comment 8 Yaniv Kaul 2012-06-21 09:32:51 EDT
(In reply to comment #7)
> To be honest, I do not know the reason behind this. I just followed test
> cases which are mentioned in this bug and they explicitly say it should not
> be possible, so I reported a bug.

http://www.ovirt.org/wiki/Features/DetailedHotPlug#User_work-flows says:
"4. VM should be in status Up"
Comment 9 Itamar Heim 2012-06-21 16:03:40 EDT
livnat - please see comments 6 to 8 above.
Comment 10 lpeer 2012-07-04 03:04:49 EDT
(In reply to comment #9)
> livnat - please see comments 6 to 8 above.

I don't see a reason not to support this when the VM is in status powering-up.
Other VM statuses mentioned in this bug should be blocked.
Comment 12 Martin Pavlik 2012-08-09 11:17:29 EDT
It is important to get this fixed in order to cover all angles on Hot Plug NIC feature. Therfore I raised severity.
Comment 13 Muli Salem 2012-08-14 11:50:00 EDT
Proposed fix in: 

http://gerrit.ovirt.org/#/c/7176/
Comment 14 lpeer 2012-08-16 05:54:40 EDT
(In reply to comment #9)
> livnat - please see comments 6 to 8 above.

After discussing this with Haim Ateya, he said we must have operating system fully activated otherwise hot plug won't work.

so we'll keep it blocked for powering up status.

Note You need to log in before you can comment on or make changes to this bug.