Bug 826948 - Early Glance service failures are not logged
Early Glance service failures are not logged
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: openstack-glance (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 831713
  Show dependency treegraph
 
Reported: 2012-05-31 05:45 EDT by David Naori
Modified: 2016-01-04 09:45 EST (History)
13 users (show)

See Also:
Fixed In Version: 2015.1.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 831713 (view as bug list)
Environment:
Last Closed: 2015-09-18 15:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Naori 2012-05-31 05:45:58 EDT
Description of problem:
Glance services fail to start if python-keystone package is missing. 
No errors in logs or any other clue...

[root@camel-glance ~]# /etc/init.d/openstack-glance-api start
Starting openstack-glance-api:                             [  OK  ]
[root@camel-glance ~]# echo $?
0
[root@camel-glance ~]# /etc/init.d/openstack-glance-api status
openstack-glance-api dead but pid file exists
[root@camel-glance ~]# cat /var/log/glance/api.log 
[root@camel-glance ~]# 

nothing in /var/log/messages either.

After installing python-keystone the services are starting successfully.

Version-Release number of selected component (if applicable):
openstack-glance-2012.1-10.el6.noarch

How reproducible:
100%
  
Actual results:
Services fail to start

Expected results:
1) Log an error.
2) Maybe add python-keystone as a dependency for glance.
Comment 1 Pádraig Brady 2012-05-31 06:24:09 EDT
So the dependency issue should probably solved through documentation which I'm looking at now. I.E. specify to install python-keystone-auth-token if using keystone auth.

There is an issue here though that glance doesn't output anything to the log.
This is probably very similar to the silent failure mode of bug #826120.
I.E. since this is a dependency issue, the error occurs before logging is set up.

This should be improved.

Perhaps we should ensure stderr is redirected to the appropriate log.

Or maybe we should add a --check option that loads as much as possible but exists as quickly as possible.

Need to investigate a bit...
Comment 2 Fedora Update System 2015-08-21 10:21:25 EDT
openstack-heat-2015.1.1-1.fc23 openstack-ceilometer-2015.1.1-1.fc23 openstack-neutron-2015.1.1-1.fc23 openstack-ironic-2015.1.1-1.fc23 openstack-sahara-2015.1.1-1.fc23 openstack-cinder-2015.1.1-1.fc23 openstack-glance-2015.1.1-1.fc23 openstack-nova-2015.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=826948
Comment 3 Fedora Update System 2015-08-22 12:24:43 EDT
openstack-ceilometer-2015.1.1-1.fc23, openstack-cinder-2015.1.1-1.fc23, openstack-glance-2015.1.1-1.fc23, openstack-heat-2015.1.1-1.fc23, openstack-ironic-2015.1.1-1.fc23, openstack-neutron-2015.1.1-1.fc23, openstack-nova-2015.1.1-1.fc23, openstack-sahara-2015.1.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update openstack-nova openstack-glance openstack-cinder openstack-sahara openstack-ironic openstack-neutron openstack-ceilometer openstack-heat'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13914
Comment 4 Fedora Update System 2015-09-18 15:02:21 EDT
openstack-ceilometer-2015.1.1-1.fc23, openstack-cinder-2015.1.1-1.fc23, openstack-glance-2015.1.1-1.fc23, openstack-heat-2015.1.1-1.fc23, openstack-ironic-2015.1.1-1.fc23, openstack-neutron-2015.1.1-1.fc23, openstack-nova-2015.1.1-1.fc23, openstack-sahara-2015.1.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.