Bug 827008 - (libkcddb) Review Request: libkcddb - A KDE CDDB retrieval library
Review Request: libkcddb - A KDE CDDB retrieval library
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-reviews kscd
  Show dependency treegraph
 
Reported: 2012-05-31 08:16 EDT by Jaroslav Reznik
Modified: 2012-06-12 12:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 20:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rdieter: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2012-05-31 08:16:44 EDT
Spec URL: http://rezza.hofyland.cz/fedora/packages/kdemultimedia/libkcddb.spec
SRPM URL: http://rezza.hofyland.cz/fedora/packages/kdemultimedia/libkcddb-4.8.80-1.fc16.src.rpm
Description: A KDE CDDB retrieval library.
Fedora Account System Username: jreznik

http://koji.fedoraproject.org/koji/taskinfo?taskID=4116686

rpmlint libkcddb-4.8.80-1.fc16.x86_64.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

rpmlint libkcddb-4.8.80-1.fc16.src.rpm 
libkcddb.src: W: invalid-url Source0: ftp://ftp.kde.org/pub/kde/unstable/4.8.80/src/libkcddb-4.8.80.tar.xz <urlopen error ftp error: 550 Failed to change directory.>
1 packages and 0 specfiles checked; 0 errors, 1 warnings.

(pre packages)
Comment 1 Rex Dieter 2012-05-31 15:41:34 EDT
The only thing I see really is to fixup conflicts:

1.
Conflicts:  kdemultimedia-libs < 6:4.8.80-1 
and -devel:
Conflicts:  kdemultimedia-devel < 6:4.8.80-1


otherwise, the rest is a relatively simple library

naming: ok

sources: ok

licensing: ok

scriptlets: ok

macros: ok


APPROVED (item 1 can be done post review, prior to building)
Comment 2 Kevin Kofler 2012-05-31 16:02:28 EDT
BuildRequires:  kdelibs-devel >= %{version}
is not going to work (missing Epoch), please use:
BuildRequires:  kdelibs4-devel >= %{version}
instead. (The virtual Provides has no Epoch, among other reasons.)
Comment 4 Jaroslav Reznik 2012-06-04 07:46:26 EDT
New Package SCM Request
=======================
Package Name: libkcddb
Short Description: A KDE CDDB retrieval library
Owners: jreznik ltinkl rdieter than kkofler
Branches: f17
InitialCC:
Comment 5 Gwyn Ciesla 2012-06-04 08:08:55 EDT
Git done (by process-git-requests).
Comment 6 Rex Dieter 2012-06-08 20:01:33 EDT
imported

Note You need to log in before you can comment on or make changes to this bug.