Bug 827012 - 3.1 [VDSM] beta1 [Hot plug NIC] hotplug NIC stops working after VM live snapshot is created
3.1 [VDSM] beta1 [Hot plug NIC] hotplug NIC stops working after VM live snaps...
Status: CLOSED DUPLICATE of bug 842771
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: 6.4
Assigned To: Igor Lvovsky
Martin Pavlik
network
:
Depends On:
Blocks: 581266 833637 835390 835392
  Show dependency treegraph
 
Reported: 2012-05-31 08:30 EDT by Martin Pavlik
Modified: 2015-04-06 23:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 04:13:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (98.02 KB, application/x-gzip)
2012-05-31 08:30 EDT, Martin Pavlik
no flags Details
libvirt.log (416.77 KB, application/x-gzip)
2012-05-31 08:35 EDT, Martin Pavlik
no flags Details
screenshot 1 (162.51 KB, image/png)
2012-05-31 08:36 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-31 08:30:33 EDT
Created attachment 588066 [details]
vdsm.log + engine.log

Description of problem:
It is not possible to hotplug/hotunplug NIC from VM after VM snapshot is created

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
1) create VM with windows7 (install virtIO driver for NIC)
2) add 2 NIC to VM (1 activated, 1 deactivated)
3) start VM
4) create snapshot of running VM
5) try to decativate active NIC
  
Actual results:
hotplug NIC stops working after VM snapshot is created

Expected results:
hotplug NIC should be working without error after VM snapshot is created

Additional info:
No error is reported in events

engine.log
2012-05-31 14:17:42,925 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (pool-10-thread-47) [289b8ea0] Command HotUnplugNicVDS execution failed. Exception: XmlRpcRunTimeException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
2012-05-31 14:17:42,926 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HotUnplugNicVDSCommand] (pool-10-thread-47) [289b8ea0] FINISH, HotUnplugNicVDSCommand, log id: 28771028
2012-05-31 14:17:42,927 ERROR [org.ovirt.engine.core.bll.HotPlugUnplugVmNicCommand] (pool-10-thread-47) [289b8ea0] Command org.ovirt.engine.core.bll.HotPlugUnplugVmNicCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.xmlrpc.XmlRpcRunTimeException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
Comment 1 Martin Pavlik 2012-05-31 08:35:50 EDT
Created attachment 588067 [details]
libvirt.log
Comment 2 Martin Pavlik 2012-05-31 08:36:12 EDT
Created attachment 588068 [details]
screenshot 1
Comment 7 Mike Kolesnik 2012-08-09 04:22:32 EDT
There are two issues here, both should be solved on VDSM side:

 1. The returned value contains a dictionary for key 'vmList' which contains a field (in a device sub-dictionary) with value None which causes XML RPC parser to crash at engine side.
 2. The engine does not look at the vmList dictionary in any of the plug/unplug (nic/disk) actions, so not returning it will definitely solve the reported bug.

Please fix as you deem correct on VDSM side.
Comment 9 Dan Kenigsberg 2012-08-13 04:13:37 EDT
Mike: the None element is mirror/mirrorPath just as in bug 842771

*** This bug has been marked as a duplicate of bug 842771 ***

Note You need to log in before you can comment on or make changes to this bug.