Bug 827029 - IndexOutOfBoundsException when opening bpmn process
IndexOutOfBoundsException when opening bpmn process
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity high
: CR1
: 5.3.0 GA
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:24 EDT by Len DiMaggio
Modified: 2014-10-15 13:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-15 13:25:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-11984 None Closed IndexOutOfBoundsException when opening bpmn process 2012-06-12 20:10:57 EDT

  None (edit)
Description Len DiMaggio 2012-05-31 09:24:59 EDT
Description of problem:

Link to: https://issues.jboss.org/browse/JBIDE-11984

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2012-06-01 09:18:30 EDT
Kris Verlaenen <kris.verlaenen@gmail.com> made a comment on jira JBIDE-11984

Solved (on master and 5.3.x).

It makes me wonder though, as it shows that we're still configuring the Drools plugin to only show a subset of the nodes by default (if you go to Preferences -> Drools not all nodes are checked in the installed drools nodes).  This used to be necessary in the past, where only a subset was supported as part of BRMS and Drools Flow was not supported, but since that editor is now also used by jBPM and all nodes are supported there, I would really like to recommend we remove this, and make sure all nodes are visible in the palette by default.

I know this is done by setting a preference by default for JBDS that disables a part of the nodes by default, can we remove this for BRMS 5.3?
Comment 2 JBoss JIRA Server 2012-06-01 09:40:23 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-11984

Patch for JBDS product:

Index: plugin_customization.ini
===================================================================
--- plugin_customization.ini	(revision 9605)
+++ plugin_customization.ini	(working copy)
@@ -55,7 +55,7 @@
 org.eclipse.jst.ws.consumption.ui/PREFERENCE_RUNTIME=org.jboss.tools.ws.creation.jbossWebServiceRT
 
 # Disable non-product features in Drools Flow palette by default
-org.drools.eclipse/Drools.FlowNodes = 1111110000000
+#org.drools.eclipse/Drools.FlowNodes = 1111110000000
 
 # Added to fix https://jira.jboss.org/jira/browse/JBDS-1072.
 # On the deployment page of the process editor, there is a property indicating
Comment 3 JBoss JIRA Server 2012-06-01 09:43:06 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-11984

Patch that needs to be applied to devstudio trunk and branch if these are to be enabled. Is not controllable by SOA plugins on their own.

Question is though if this change enables things that is not supported/allowed ?
Comment 4 JBoss JIRA Server 2012-06-01 11:37:24 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-11984

updated patch of what I committed to trunk that removes this customization of Drools Flow palette on new workspaces.
Comment 5 JBoss JIRA Server 2012-06-03 03:11:31 EDT
Douglas Palmer <dpalmer@redhat.com> updated the status of jira JBIDE-11984 to Resolved
Comment 6 JBoss JIRA Server 2012-06-03 03:11:31 EDT
Douglas Palmer <dpalmer@redhat.com> made a comment on jira JBIDE-11984

Resolving, the question of which nodes to enable is being discussed elsewhere.
Comment 9 JBoss JIRA Server 2012-06-11 02:23:43 EDT
Jiri Peterka <jpeterka@redhat.com> updated the status of jira JBIDE-11984 to Closed
Comment 10 JBoss JIRA Server 2012-06-11 02:23:43 EDT
Jiri Peterka <jpeterka@redhat.com> made a comment on jira JBIDE-11984

Verified in JBDS 5.0.0.CR1b-SOA.Beta3, L64

Note You need to log in before you can comment on or make changes to this bug.