Bug 827033 - emacs spell checking broken using non-default dictionary
emacs spell checking broken using non-default dictionary
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:32 EDT by Jes Sorensen
Modified: 2013-04-29 23:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-20 15:10:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2012-05-31 09:32:41 EDT
Description of problem:
Changing the dictionary from 'default' to anything else breaks spell
checking in emacs. 

Version-Release number of selected component (if applicable):
emacs-24.0.95-1.fc17.x86_64

This is a regression from emacs in Fedora 16.

How reproducible:
Every time

Steps to Reproduce:
1. M-x ispell-change-dictionary <ret> english <ret> (anything buf 'default')
2. M-x ispell-{word,buffer}
3. Error: Process ispell not running - hanging in a busy loop or something
  
Actual results:


Expected results:


Additional info (*Messages*):
Local Ispell dictionary set to nil
Starting new Ispell process [default] ...
Checking spelling of HELLO...
HELLO is correct
Making completion list...
Ispell process killed
Local Ispell dictionary set to english
Quit
Starting new Ispell process [english] ...
Checking spelling of HELLO...
ispell-send-string: Process ispell not running
Comment 1 Enrico Scholz 2012-08-19 07:31:42 EDT
This happens because fedora patches emacs to use 'hunspell' by default without adapting names of dictionaries.

E.g. with upstream ispell/aspell default, german dictionary is named 'deutsch' but 'hunspell' calls it differently ('de_DE').

$ echo | aspell -a -d deutsch 
@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.6.1)

$ echo | hunspell -a -d deutsch 
@(#) International Ispell Version 3.2.06 (but really Hunspell 1.3.2)
Can't open affix or dictionary files for dictionary named "deutsch".

ispell-dictionary-alist contains the 'deutsch' mapping and using 'hunspell' will fail hence.

Both 'aspell' and 'hunspell' support the full qualified 'de_DE' so that changing 'ispell-dictionary-alist' might be a solution. But there must be changed almost every entry and it is often ambiguously (e.g. 'deutsch' can be 'de_DE' or 'de_AT' or 'de_CH').

Adding alias support to 'hunspell' might be a better fix.

In the meantime, the emacs-spellchecker.patch should be reverted.
Comment 2 Daniel 2012-09-25 05:35:31 EDT
For me, with emacs-24.1-4.fc17.x86_64, spell checking still does not work.
Comment 3 Fedora Admin XMLRPC Client 2013-02-27 10:47:35 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Daniel 2013-02-27 15:01:51 EST
This Problem is not solved yet in emacs-24.2-6; just compiled it today.
Comment 5 Petr Hracek 2013-03-21 05:33:28 EDT
Patch could not be reverted because of that BZ
https://bugzilla.redhat.com/show_bug.cgi?id=713600

But I have tried to reproduced that error over steps like:
Steps to Reproduce:
1. M-x ispell-change-dictionary <ret> english <ret> (anything buf 'default')
2. M-x ispell-{word,buffer}

and spelling was working successfully.

my emacs version is also emacs-24.2-6.
Comment 6 Fedora Update System 2013-04-08 08:00:55 EDT
emacs-24.2-17.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-24.2-17.fc19
Comment 7 Fedora Update System 2013-04-08 08:38:41 EDT
emacs-24.2-17.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/emacs-24.2-17.fc18
Comment 8 Fedora Update System 2013-04-08 12:05:40 EDT
Package emacs-24.2-17.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.2-17.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5143/emacs-24.2-17.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-04-10 04:27:31 EDT
emacs-24.2-18.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-24.2-18.fc19
Comment 10 Fedora Update System 2013-04-12 09:02:12 EDT
emacs-24.2-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/emacs-24.2-18.fc18
Comment 11 Fedora Update System 2013-04-20 15:10:30 EDT
emacs-24.2-18.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Daniel 2013-04-21 09:33:04 EDT
Updated with yum update --enablerepo=updates-testing emacs-24.2-18.fc18.
Loaded a TEX file with german characters in it (ü,ö,ä,ß) and tried to spell check it.
Nothing changed, spell checking e.g. for german does not work. It says:

Ispell error. This UTF-8 encoding can't convert to UTF-16: 
Wrong type argument: number-or-marker-p nil

Changing the dictionary to any other does not help.
The last working version was emacs-23.3-10.
Comment 13 Daniel 2013-04-21 09:36:52 EDT
See comment of Enrico Scholz from 2012-08-19 07:31:42 EDT. Think it says it all.

echo | aspell -a -d deutsch 
@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.6.1)

echo | hunspell -a -d deutsch 
@(#) International Ispell Version 3.2.06 (but really Hunspell 1.3.2)
Can't open affix or dictionary files for dictionary named "deutsch".

hunspell -a -d de_DE
@(#) International Ispell Version 3.2.06 (but really Hunspell 1.3.2)
Comment 14 Fedora Update System 2013-04-29 23:23:40 EDT
emacs-24.2-18.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.