Bug 827086 - [abrt] evolution-3.4.1-2.fc17: get_additional_properties_cb: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.1-2.fc17: get_additional_properties_cb: Process /usr/bin...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:c6b6e451fbe5ccf0ee63683b3ad...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 10:59 EDT by Pavel Cervinka
Modified: 2012-06-06 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 08:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (56.54 KB, text/plain)
2012-05-31 10:59 EDT, Pavel Cervinka
no flags Details
File: maps (234.95 KB, text/plain)
2012-05-31 11:00 EDT, Pavel Cervinka
no flags Details
File: dso_list (29.19 KB, text/plain)
2012-05-31 11:00 EDT, Pavel Cervinka
no flags Details
File: build_ids (12.05 KB, text/plain)
2012-05-31 11:00 EDT, Pavel Cervinka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 677266 None None None 2012-06-01 08:29:48 EDT

  None (edit)
Description Pavel Cervinka 2012-05-31 10:59:47 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
crash_function: get_additional_properties_cb
executable:     /usr/bin/evolution
kernel:         3.3.7-1.fc17.i686
pid:            2196
pwd:            /home/cepal
time:           Thu 31 May 2012 03:18:52 PM BST
uid:            1000
username:       cepal

backtrace:      Text file, 57899 bytes
build_ids:      Text file, 12341 bytes
dso_list:       Text file, 29893 bytes
maps:           Text file, 240589 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/cepal/4

comment:
:I used evolution-mapy connector to connect to our corporate MS Exchange 2010 server for the first time after installing Fedora 17 (from Desktop liveCD inside virtualbox guest on Windows 7 32bit host) and it leaked RAM and after about 20 or so minuted it crashed.
:
:Steps I did since booting off the liveCD:
:- install system (ext2 /boot, ext4 /, extra SWAP disk with fixed (not dynamic) size VDK image)
:- yum upgrade
:- install kernel-devel/headers, gcc etc. and dependencies, needed for virtualbox libraries
:- reboot, install virtualbox libraries (provided by the virtualbox hypervisor)
:- reboot, install evolution-mapy, evolution-owa, evolution-exchange (and dependencies)
:- start Evolution, use MAPI connector, clicked to automatically keep local copy of all e-mails; connected to server and started syncing
:- after about 10-15 secs Evolution started leaking RAM badly and made system mostly unresponsive (but still working, no full freeze or crash, didn't have influence on the host WIndows sytem)
:- after another about 20 minutes evolution crashed (I dind't check logs yet but I am sure they are attached in this report)
:
:I gave the system 512MiB RAM and 2GiB swap. at one moment I could see in TOP that Evolution had 309MiB allocated in RES and 2.8GiB in VIRT... But I can't tell which part of Evolution was source of the awful leak.

core_backtrace:
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0x11572 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xea56 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xed99 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xfa0d e_mapi_fast_transfer_properties libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0x21112 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xea56 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xf498 - libexchangemapi-1.0.so.0 -
:c86bb6f0260b51997683b16d1845538f10a83fbc 0x56355 fxparser_parse libmapi-openchange.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xec75 - libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0xf747 e_mapi_fast_transfer_objects libexchangemapi-1.0.so.0 -
:a2bc3fe051ae4f2a7eef8bb15d0f961e7bc9cc83 0x28372 e_mapi_connection_transfer_objects libexchangemapi-1.0.so.0 -
:06090b47613e1e2dcca968f1d30aac1d8b13b3d2 0xa3f2 camel_mapi_folder_fetch_summary libcamelmapi.so -
:06090b47613e1e2dcca968f1d30aac1d8b13b3d2 0xa945 mapi_refresh_folder libcamelmapi.so -
:06090b47613e1e2dcca968f1d30aac1d8b13b3d2 0xaadc - libcamelmapi.so -
:754d54fa3a03068dac27e447ab92553e0ba65db5 0x53133 camel_folder_refresh_info_sync libcamel-1.2.so.33 -
:d7ad8f620c019f35bfd9ff20efe51a2c94876d02 0x1bc6f - libemail-engine.so -
:3feb1f407bab2e7af683b3ac97d5f7a865cd2124 0x91be - libemail-utils.so -
:e22e1e456283c0cdf171447a61c4f04e354f8b2a 0x6cd98 - libglib-2.0.so.0 -
:e22e1e456283c0cdf171447a61c4f04e354f8b2a 0x6c364 - libglib-2.0.so.0 -
:abcfe6b280fcee6f1f127d40d8f54e6b4d896f5a 0x6adf start_thread libpthread.so.0 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0xf155e clone libc.so.6 -

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=4
:HOSTNAME=jagfed17
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=100000
:GNOME_KEYRING_CONTROL=/run/user/cepal/keyring-MeQiZA
:IMSETTINGS_MODULE=none
:USER=cepal
:USERNAME=cepal
:MAIL=/var/spool/mail/cepal
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/cepal/.local/bin:/home/cepal/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/cepal
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1352
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/cepal
:SHLVL=1
:LOGNAME=cepal
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-kTGH2Smj5A,guid=6c29724416df7c94a46821880000005a
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/cepal
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-cepal-rzhnnp/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1354,unix/unix:/tmp/.ICE-unix/1354
:SSH_AUTH_SOCK=/run/user/cepal/keyring-MeQiZA/ssh
:GPG_AGENT_INFO=/run/user/cepal/keyring-MeQiZA/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2196
:DESKTOP_STARTUP_ID=gnome-shell-1580-jagfed17-evolution-4_TIME595612

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 3846                 processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       3846                 3846                 signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/cepal/.xsession-errors
:pos:	12458
:flags:	02002
:2:/home/cepal/.xsession-errors
:pos:	12458
:flags:	02002
:3:socket:[38235]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[38236]
:pos:	0
:flags:	02004002
:7:socket:[38238]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[37254]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[37283]
:pos:	0
:flags:	02004002
:12:socket:[38241]
:pos:	0
:flags:	02004002
:13:/home/cepal/.pki/nssdb/cert9.db
:pos:	2048
:flags:	02100002
:14:/var/tmp/etilqs_jq3AgsGl8DVjZRG (deleted)
:pos:	28
:flags:	02100002
:15:/var/tmp/etilqs_Yq4wRZ6UE2bEKpR (deleted)
:pos:	2056
:flags:	02500002
:16:/var/tmp/etilqs_vvksfYxtxVmOT5n (deleted)
:pos:	2048
:flags:	02500002
:17:/home/cepal/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:18:/var/tmp/etilqs_moyZmUPYgB2HKnm (deleted)
:pos:	28
:flags:	02100002
:19:/var/tmp/etilqs_7nkWY3hJbpWNGJ1 (deleted)
:pos:	2056
:flags:	02500002
:20:/var/tmp/etilqs_PHK4kYqtdiUi7IK (deleted)
:pos:	2048
:flags:	02500002
:21:/etc/pki/nssdb/cert9.db
:pos:	2048
:flags:	02100000
:22:/var/tmp/etilqs_UvvYG6Fs397OMGy (deleted)
:pos:	28
:flags:	02100002
:23:/var/tmp/etilqs_GLHOyNz3o8GH0hH (deleted)
:pos:	2048
:flags:	02500002
:24:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:25:/var/tmp/etilqs_GykfsnufkbVTsx2 (deleted)
:pos:	28
:flags:	02100002
:26:/var/tmp/etilqs_rVwBDFpHbu8XgEG (deleted)
:pos:	2048
:flags:	02500002
:27:/home/cepal/.local/share/evolution/mail/local/folders.db
:pos:	40
:flags:	02100002
:28:/home/cepal/.local/share/evolution/mail/local/..ibex.index
:pos:	6144
:flags:	0100002
:29:/home/cepal/.local/share/evolution/mail/local/..ibex.index.data
:pos:	0
:flags:	0102002
:30:/home/cepal/.local/share/evolution/mail/local/.Drafts.ibex.index
:pos:	6144
:flags:	0100002
:31:/home/cepal/.local/share/evolution/mail/local/.Drafts.ibex.index.data
:pos:	0
:flags:	0102002
:32:/home/cepal/.local/share/evolution/mail/local/.Outbox.ibex.index
:pos:	6144
:flags:	0100002
:33:/home/cepal/.local/share/evolution/mail/local/.Outbox.ibex.index.data
:pos:	0
:flags:	0102002
:34:/home/cepal/.local/share/evolution/mail/local/.Sent.ibex.index
:pos:	6144
:flags:	0100002
:35:/home/cepal/.local/share/evolution/mail/local/.Sent.ibex.index.data
:pos:	0
:flags:	0102002
:36:/home/cepal/.local/share/evolution/mail/local/.Templates.ibex.index
:pos:	6144
:flags:	0100002
:37:/home/cepal/.local/share/evolution/mail/local/.Templates.ibex.index.data
:pos:	0
:flags:	0102002
:38:/home/cepal/.local/share/evolution/mail/vfolder/folders.db
:pos:	40
:flags:	02100002
:39:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:40:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:41:anon_inode:inotify
:pos:	0
:flags:	02004000
:42:socket:[38256]
:pos:	0
:flags:	02004002
:43:socket:[37325]
:pos:	0
:flags:	02004002
:44:socket:[37328]
:pos:	0
:flags:	02004002
:45:/dev/urandom
:pos:	0
:flags:	02000000
:46:/home/cepal/.cache/evolution/mail/1338473517.2196.2@jagfed17/folders.db
:pos:	40
:flags:	02100002
:47:anon_inode:[eventpoll]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: b6551988-54a0-4875-8ee6-d8bea3413b6a
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4789.28
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 2
:CPU Speed: 2394
:System Memory: 497
:System Swap: 2046
:Vendor: innotek GmbH
:System: VirtualBox 1.2
:Form factor: Unknown
:Kernel: 3.3.7-1.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(33006:48879:0:0) pci, None, VIDEO, VirtualBox Graphics Adapter
:(32902:28947:0:0) pci, None, BRIDGE, 82371AB/EB/MB PIIX4 ACPI
:(32902:10169:32902:29296) pci, None, PCI/ISA, 82801GBM (ICH7-M) LPC Interface Bridge
:(32902:4110:32902:30) pci, e1000, ETHERNET, PRO/1000 MT Desktop Adapter
:(4203:63:0:0) pci, ohci_hcd, USB, KeyLargo/Intrepid USB
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(33006:51966:0:0) pci, None, BASE, VirtualBox Guest Service
:(32902:10281:0:0) pci, ahci, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller
:(32902:9832:33668:30336) pci, snd_hda_intel, MULTIMEDIA, 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 4123565 2836723 2816073 1040384 877281 877281
:/dev/sda1 /boot ext2 1024 1024 245983 187338 174538 64000 63652 63652
:

var_log_messages:
:May 31 15:11:34 jagfed17 yum[2184]: Installed: evolution-mapi-3.4.1-3.fc17.i686
:May 31 15:11:36 jagfed17 yum[2184]: Installed: evolution-exchange-3.4.1-1.fc17.i686
:May 31 15:11:36 jagfed17 yum[2184]: Installed: evolution-ews-3.4.1-1.fc17.i686
:May 31 15:28:53 jagfed17 abrt[2280]: Saved core dump of pid 2196 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-31-15:18:52-2196 (2914865152 bytes)
Comment 1 Pavel Cervinka 2012-05-31 10:59:53 EDT
Created attachment 588130 [details]
File: backtrace
Comment 2 Pavel Cervinka 2012-05-31 11:00:00 EDT
Created attachment 588131 [details]
File: maps
Comment 3 Pavel Cervinka 2012-05-31 11:00:03 EDT
Created attachment 588132 [details]
File: dso_list
Comment 4 Pavel Cervinka 2012-05-31 11:00:05 EDT
Created attachment 588133 [details]
File: build_ids
Comment 5 Milan Crha 2012-06-01 08:29:48 EDT
Thanks for a bug report and detailed steps. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions. Te initial observation suggests that the crash is related to the "sync for offline use" option in account's preferences. turning that option off will not use this particular part of the code - at least not that heavily like it does currently.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=677266
Comment 6 Milan Crha 2012-06-05 09:57:00 EDT
I cannot reproduce the crash myself, but I suppose, when it gets out of memory, that the leaking caused the crash. I'm investigating this further in the upstream bug.
Comment 7 Milan Crha 2012-06-06 05:10:41 EDT
I built a test package for you here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4131890

Could you install it and try again, please? Note this requires evolution from updates-testing. Also, to be sure you download exactly the same as before, erase also ~/.cache/evolution/mail/<mapi-account-uid>/ folder. If you are not using any other accounts, then there will be only one such folder. On the other hand, the .cache folder contains only local copies of remote data, thus deleting from it anything will not cause any issue, except of re-download of data from the server.

Note You need to log in before you can comment on or make changes to this bug.