Bug 827107 - Nouveau not working on Lenovo T420
Nouveau not working on Lenovo T420
Status: CLOSED DUPLICATE of bug 752613
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-31 11:56 EDT by klement.sekera
Modified: 2013-05-15 10:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-05-15 10:37:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description klement.sekera 2012-05-31 11:56:26 EDT
When discrete graphics is selected in BIOS after installing the Fedora to force the NVIDIA card to be used, then the boot process freezes right after the grub prompt (the logo is not displayed at all).

When optimus is selected, the nouveau driver is not used, instead, the intel graphics in the cpu is used.
Comment 1 Adam Williamson 2013-05-14 16:32:27 EDT
Assigning to correct component. Can you please provide as much of the data listed at https://fedoraproject.org/wiki/How_to_debug_Xorg_problems as possible? Is this still the case with latest F17 updates, or with F18/F19 if you've upgraded? Thanks!
Comment 2 klement.sekera 2013-05-15 03:53:27 EDT
Hi, the boot process freeze is tied to another bug and can be worked around by disabling vt-d support in virtualization settings in bios.

I don't know about nouveau anymore, since I switched to binary nvidia drivers some time ago.
Comment 3 Adam Williamson 2013-05-15 10:36:35 EDT
Thanks. Is there already a report for the other bug? If so, we could close this.
Comment 4 Adam Williamson 2013-05-15 10:37:23 EDT
Ah, I knew I knew it already. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=752613

*** This bug has been marked as a duplicate of bug 752613 ***

Note You need to log in before you can comment on or make changes to this bug.