Bug 827108 - CLI reads "activation key" instead of "gpg key" for update in help.
CLI reads "activation key" instead of "gpg key" for update in help.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 11:57 EDT by Corey Welton
Modified: 2015-05-04 21:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The command line help reference for "gpg key" is incorrect in several places. "gpg key" is referred to as "activation key". This fix corrects the "gpg key" references.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:22:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-05-31 11:57:07 EDT
Description of problem:
When user runs "katello gpg_key help", some of the help text reads "activation key" instead of of "gpg key"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  katello gpg_key help
2.  view results
  
Actual results:
Usage: katello <options> gpg_key <action> <options>
Supported Actions:
	create         create a gpg key
	info           show information about a gpg key
	list           list all GPG keys
	update         update an activation key
	delete         delete an gpg key


Expected results:
Usage: katello <options> gpg_key <action> <options>
Supported Actions:
	create         create a gpg key
	info           show information about a gpg key
	list           list all GPG keys
	update         update an gpg key
	delete         delete an gpg key


Additional info:

katello-cli-0.1.107-1.el6.noarch
Comment 1 Corey Welton 2012-05-31 11:57:57 EDT
actually, while we're at it, it should probably read "a gpg key" for both update and delete, not "an".
Comment 2 Petr Chalupa 2012-06-04 07:19:51 EDT
fixed in 3b42234f0ecd7c5ab9918e14c2abea4aed533ba5
Comment 4 Corey Welton 2012-09-17 11:23:48 EDT
QE Verified.
Comment 5 Mike McCune 2012-10-24 10:22:09 EDT
closing, currentrelease since these seemingly got missed in the 1.0.1 errata

Note You need to log in before you can comment on or make changes to this bug.