Bug 827116 - [RFE] add --leavebootorder option to bootloader
[RFE] add --leavebootorder option to bootloader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 824801
  Show dependency treegraph
 
Reported: 2012-05-31 12:27 EDT by Bill Peck
Modified: 2013-10-24 03:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 21:53:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-05-31 12:27:47 EDT
Description of problem:

The default feature for anaconda is to change the boot order on systems that support this.  ie: ppc and uefi systems.  This is normaly what you want since you want to boot what you just installed.

This presents a problem for automation systems which expect the system to continue to netboot first and then fall back to localboot.

We would like an option that would tell anaconda to not modify the boot order.

Please see attached bz
Comment 1 Bill Peck 2012-05-31 12:29:01 EDT
doesn't seem to be a field for related bugs..

https://bugzilla.redhat.com/show_bug.cgi?id=824801
Comment 2 Marian Ganisin 2012-06-01 03:11:12 EDT
Traditionally installer doesn't change boot order, in my opinion it seems to be better idea to keep it unchanged by default and change it according to user's request. Therefore option like --update-boot-order could be considered. Such solution is much more predictable as this is in accordance to architectures which are unable to change boot order and as I said this is legacy behavior.
Comment 3 Mark Hamzy 2012-06-01 10:54:04 EDT
Fedora 17 for the PPC will change the boot order by default.  I don't think we should switch that around again for the next release.  It would be too confusing.

I'll take a stab at implementing this...
Comment 5 Bill Peck 2012-06-11 08:41:49 EDT
Mark,

Will this work for ia64 (efi) systems as well?  I hope it will since the same issue happens there.

Thanks!
Comment 6 Mark Hamzy 2012-06-11 11:18:52 EDT
Bill,

This patch does not modify EFIGRUB or MacEFIGRUB classes within pyanaconda/bootloader.py.  I do not have access to these systems to verify that any changes would work as intended.

Maybe for:

class EFIGRUB(GRUB):
...
    def install(self):
        self.remove_efi_boot_target()
        self.add_efi_boot_target()
...

make remove_efi_boot_target() conditional on flags.leavebootorder?

MacEFIGRUB doesn't seem to update the boot order.
Comment 7 Chris Lumens 2012-06-22 10:59:40 EDT
This is on master now.
Comment 8 Jack Reed 2012-11-19 19:59:25 EST
I will add the kickstart option to the Installation Guide for F18, and have added the boot option to the Boot Options wiki page, noting that it is new to F18. 

I won't add the boot option to the Installation Guide because it is one of many specialised boot options that are reserved for the greater space afforded by the wiki.
Comment 9 Adam Williamson 2013-05-09 21:53:30 EDT
Checked current anaconda master, the code backing this option is in place for both PPC and UEFI. I'm too lazy to test it (I'd have to reboot!), so let's just close it out. If there are bugs in the implementation, file 'em separately.

Note You need to log in before you can comment on or make changes to this bug.