Bug 827123 - f17 AMD-Vi: Event logged on device device=01:00.0 (it is the VGA card) fx6100 990fx caicos
f17 AMD-Vi: Event logged on device device=01:00.0 (it is the VGA card) fx6100...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 12:54 EDT by Reartes Guillermo
Modified: 2012-08-13 09:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 09:56:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (92.43 KB, application/octet-stream)
2012-05-31 12:54 EDT, Reartes Guillermo
no flags Details
Issue no longer happens with currrent kernel (87.18 KB, text/plain)
2012-07-21 09:56 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-05-31 12:54:03 EDT
Created attachment 588157 [details]
dmesg

Description of problem:

I see these in the logs (i never saw them before in previous fedora):

Freeing unused kernel memory: 12k freed
Freeing unused kernel memory: 1516k freed
[drm] Initialized drm 1.1.0 20060810
[drm] radeon defaulting to kernel modesetting.
[drm] radeon kernel modesetting enabled.
fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
Console: switching to colour dummy device 80x25
[drm] initializing kernel modesetting (CAICOS 0x1002:0x6779 0x1682:0x3200).
[drm] register mmio base: 0xFEA20000
[drm] register mmio size: 131072
ATOM BIOS: C26401
radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
radeon 0000:01:00.0: GTT: 512M 0x0000000040000000 - 0x000000005FFFFFFF
[drm] Detected VRAM RAM=1024M, BAR=256M
[drm] RAM width 64bits DDR
[TTM] Zone  kernel: Available graphics memory: 8190234 kiB.
[TTM] Zone   dma32: Available graphics memory: 2097152 kiB.
[TTM] Initializing pool allocator.
[TTM] Initializing DMA pool allocator.
[drm] radeon: 1024M of VRAM memory ready
[drm] radeon: 512M of GTT memory ready.
[drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[drm] Driver supports precise vblank timestamp query.
radeon 0000:01:00.0: radeon: using MSI.
[drm] radeon: irq initialized.
[drm] GART: num cpu pages 131072, num gpu pages 131072
[drm] radeon: ib pool ready.
[drm] Loading CAICOS Microcode
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9000 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ea900 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9200 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9040 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9240 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9080 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9280 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e92c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e90c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9100 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9140 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9180 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e91c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eaac0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eabc0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ea940 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eac00 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ea980 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eac40 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ea9c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eab00 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eaa00 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eab40 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eaa40 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eab80 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eaa80 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9300 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9340 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9380 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e93c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9400 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9440 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eac80 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ead00 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eacc0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ead40 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9480 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e94c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9500 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9540 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002ead80 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eadc0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eae00 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eae40 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eae80 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9580 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e95c0 flags=0x0010]
AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002eaec0 flags=0x0010]
[drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
radeon 0000:01:00.0: WB enabled
[drm] fence driver on ring 0 use gpu addr 0x40000c00 and cpu addr 0xffff880422d14c00
[drm] ring test on 0 succeeded in 2 usecs
[drm] ib test on ring 0 succeeded in 0 usecs
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm]   HDMI-A
[drm]   HPD2
[drm]   DDC: 0x6460 0x6460 0x6464 0x6464 0x6468 0x6468 0x646c 0x646c
[drm]   Encoders:
[drm]     DFP1: INTERNAL_UNIPHY1
[drm] Connector 1:
[drm]   DVI-I
[drm]   HPD4
[drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
[drm]   Encoders:
[drm]     DFP2: INTERNAL_UNIPHY
[drm] Connector 2:
[drm]   VGA
[drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
[drm]   Encoders:
[drm]     CRT1: INTERNAL_KLDSCP_DAC1
[drm] Internal thermal controller without fan control
[drm] radeon: power management initialized
[drm] fb mappable at 0xC0142000
[drm] vram apper at 0xC0000000
[drm] size 9216000
[drm] fb depth is 24
[drm]    pitch is 7680
fbcon: radeondrmfb (fb0) is primary device



Version-Release number of selected component (if applicable):

os: Fedora 17 X86_64
kernel: 3.3.7-1.fc17.x86_64

How reproducible:

allways

Steps to Reproduce:
1. boot
  
Actual results:

No known consequences aside from these logged 'events'.

Expected results:


Additional info:
Comment 1 Reartes Guillermo 2012-06-24 22:59:18 EDT
Update:

AMD-Vi: Event logged [IO_PAGE_FAULT device=01:00.0 domain=0x0016 address=0x0000000f002e9000 flags=0x0010]

It only happens at POWER-ON.
So it can only be reproduced by doing a POWER-CYCLE.

When just REBOOTING, the "page fault" does not "happen".
Comment 2 Reartes Guillermo 2012-07-21 09:56:13 EDT
Created attachment 599527 [details]
Issue no longer happens with currrent kernel

The message disapeared some time ago.
Currently using 3.4.5-2.fc17.x86_64 it does not happen.

Just in case,my cmdline is: 

$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.4.5-2.fc17.x86_64 root=UUID=7397103e-0f3c-4baf-88b2-b78b9ebd46e5 ro rd.lvm=0 rd.dm=0 SYSFONT=True rd.luks=0 rd.md.uuid=ac77fae7:76d15e01:01514632:90362bee KEYTABLE=es rd.md.uuid=d5c73c12:bd42892e:e7dec3f4:514ffebd LANG=en_US.UTF-8 rhgb quiet radeon.pcie_gen2=1 iommu=pt amd_iommu_dump r8169.debug=16

This bugreport can be closed.
Comment 3 Reartes Guillermo 2012-08-13 08:22:28 EDT
I can confirm that the issue seems to be gone.

Please close bug-report. 

$ uname -r
3.5.1-1.fc17.x86_64

$ dmesg| grep -i amd-vi
[    1.761985] AMD-Vi: device: 00:00.2 cap: 0040 seg: 0 flags: 3e info 1300
[    1.761988] AMD-Vi:        mmio-addr: 00000000feb20000
[    1.762205] AMD-Vi:   DEV_SELECT_RANGE_START  devid: 00:00.0 flags: 00
[    1.762206] AMD-Vi:   DEV_RANGE_END           devid: 00:00.2
[    1.762208] AMD-Vi:   DEV_SELECT                      devid: 00:02.0 flags: 00
[    1.762209] AMD-Vi:   DEV_SELECT_RANGE_START  devid: 01:00.0 flags: 00
[    1.762210] AMD-Vi:   DEV_RANGE_END           devid: 01:00.1
[    1.762211] AMD-Vi:   DEV_SELECT                      devid: 00:04.0 flags: 00
[    1.762213] AMD-Vi:   DEV_SELECT                      devid: 02:00.0 flags: 00
[    1.762214] AMD-Vi:   DEV_SELECT                      devid: 00:05.0 flags: 00
[    1.762215] AMD-Vi:   DEV_SELECT                      devid: 03:00.0 flags: 00
[    1.762216] AMD-Vi:   DEV_SELECT                      devid: 00:06.0 flags: 00
[    1.762217] AMD-Vi:   DEV_SELECT                      devid: 04:00.0 flags: 00
[    1.762218] AMD-Vi:   DEV_SELECT                      devid: 00:09.0 flags: 00
[    1.762219] AMD-Vi:   DEV_SELECT                      devid: 05:00.0 flags: 00
[    1.762221] AMD-Vi:   DEV_SELECT                      devid: 00:11.0 flags: 00
[    1.762222] AMD-Vi:   DEV_SELECT_RANGE_START  devid: 00:12.0 flags: 00
[    1.762223] AMD-Vi:   DEV_RANGE_END           devid: 00:12.2
[    1.762224] AMD-Vi:   DEV_SELECT_RANGE_START  devid: 00:13.0 flags: 00
[    1.762225] AMD-Vi:   DEV_RANGE_END           devid: 00:13.2
[    1.762227] AMD-Vi:   DEV_SELECT                      devid: 00:14.0 flags: d7
[    1.762228] AMD-Vi:   DEV_SELECT                      devid: 00:14.3 flags: 00
[    1.762229] AMD-Vi:   DEV_SELECT                      devid: 00:14.4 flags: 00
[    1.762231] AMD-Vi:   DEV_ALIAS_RANGE                 devid: 06:00.0 flags: 00 devid_to: 00:14.4
[    1.762232] AMD-Vi:   DEV_RANGE_END           devid: 06:1f.7
[    1.762241] AMD-Vi:   DEV_SELECT                      devid: 00:14.5 flags: 00
[    1.762242] AMD-Vi:   DEV_SELECT                      devid: 00:15.0 flags: 00
[    1.762243] AMD-Vi:   DEV_SELECT                      devid: 07:00.0 flags: 00
[    1.762245] AMD-Vi:   DEV_SELECT                      devid: 00:15.1 flags: 00
[    1.762246] AMD-Vi:   DEV_SELECT                      devid: 08:00.0 flags: 00
[    1.762247] AMD-Vi:   DEV_SELECT_RANGE_START  devid: 00:16.0 flags: 00
[    1.762248] AMD-Vi:   DEV_RANGE_END           devid: 00:16.2
[    1.762320] AMD-Vi: Enabling IOMMU at 0000:00:00.2 cap 0x40
[    1.815608] AMD-Vi: Initialized for Passthrough Mode

Note You need to log in before you can comment on or make changes to this bug.