Bug 827128 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'execute' accesses on the file /home/thomas/.orc/orcexec.yryRah (deleted).
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'execute' accesse...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ba00d47acbf84e926060feca580...
:
: 828870 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 13:02 EDT by tuxor
Modified: 2012-07-19 05:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 12:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tuxor 2012-05-31 13:02:58 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Do 31 Mai 2012 19:03:10 CEST

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'execute' accesses on the file /home/tuxor/.orc/orcexec.yryRah (deleted).
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If sie denken, dass totem-video-thumbnailer standardmässig erlaubt sein sollte, execute Zugriff auf orcexec.yryRah (deleted) file zu erhalten.
:Then sie sollten dies als Fehler melden.
:Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
:Do
:zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
:# grep mpegaudioparse0 /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:gstreamer_home_t:s0
:Target Objects                /home/tuxor/.orc/orcexec.yryRah (deleted) [ file
:                              ]
:Source                        mpegaudioparse0
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           totem-3.4.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP
:                              Mon May 21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   10
:First Seen                    Do 31 Mai 2012 19:01:32 CEST
:Last Seen                     Do 31 Mai 2012 19:01:33 CEST
:Local ID                      8db66e63-7d8a-4df5-8b9e-6415bc8bfe09
:
:Raw Audit Messages
:type=AVC msg=audit(1338483693.118:156): avc:  denied  { execute } for  pid=4331 comm="mpegaudioparse0" path=2F686F6D652F74686F6D61732F2E6F72632F6F7263657865632E797279526168202864656C6574656429 dev="dm-2" ino=1050756 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gstreamer_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338483693.118:156): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=10000 a2=5 a3=1 items=0 ppid=3853 pid=4331 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=mpegaudioparse0 exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mpegaudioparse0,thumb_t,gstreamer_home_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-31 13:33:05 EDT
Fixed in selinux-policy-3.10.0-129.fc17
Comment 2 tuxor 2012-06-08 15:14:16 EDT
Unfortunately it's still there with selinux-policy-3.10.0-129.fc17.noarch
(I tried the build from koji)
Comment 3 Daniel Walsh 2012-06-11 09:26:57 EDT
Unfortunately your right.

Miroslav we need thumb.te from F18 backported to F17

Specifically:
	gnome_exec_gstreamer_home_files(thumb_t)
Comment 4 Daniel Walsh 2012-06-11 09:29:06 EDT
*** Bug 828870 has been marked as a duplicate of this bug. ***
Comment 5 tuxor 2012-06-11 17:00:36 EDT
Looks like selinux-policy-3.10.0-130.fc17 from koji fixes it. Maybe we leave this bug report open until the update has been pushed to stable.
Comment 6 Dmitry Ermolchik 2012-06-14 15:01:20 EDT
I have same problem. Waiting for update.

Error log:
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'execute' accesses on the file /home/dimer/.orc/orcexec.Z1Ljjf (deleted).

*****  Plugin catchall (100. confidence) suggests  ***************************

If вы считаете, что totem-video-thumbnailer следует разрешить доступ execute к orcexec.Z1Ljjf (deleted) file по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
чтобы разрешить доступ, выполните:
# grep multiqueue0:src /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:gstreamer_home_t:s0
Target Objects                /home/dimer/.orc/orcexec.Z1Ljjf (deleted) [ file ]
Source                        multiqueue0:src
Source Path                   /usr/bin/totem-video-thumbnailer
Port                          <Неизвестно>
Host                          (removed)
Source RPM Packages           totem-3.4.2-1.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux Dim4.Home 3.4.0-1.fc17.x86_64 #1 SMP Sun Jun
                              3 06:35:17 UTC 2012 x86_64 x86_64
Alert Count                   1
First Seen                    Ср. 13 июня 2012 22:39:42
Last Seen                     Ср. 13 июня 2012 22:39:42
Local ID                      231655a5-996a-4447-a518-e2890ae83542

Raw Audit Messages
type=AVC msg=audit(1339612782.651:123): avc:  denied  { execute } for  pid=3167 comm="multiqueue0:src" path=2F686F6D652F64696D65722F2E6F72632F6F7263657865632E5A314C6A6A66202864656C6574656429 dev="dm-2" ino=263298 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gstreamer_home_t:s0 tclass=file


type=SYSCALL msg=audit(1339612782.651:123): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=10000 a2=5 a3=1 items=0 ppid=2262 pid=3167 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=multiqueue0:src exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: multiqueue0:src,thumb_t,gstreamer_home_t,file,execute

audit2allowunable to open /sys/fs/selinux/policy:  Permission denied


audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
Comment 7 Daniel Walsh 2012-06-14 15:45:10 EDT
Fixed in selinux-policy-3.10.0-130.fc17
Comment 8 Fedora Update System 2012-06-19 03:57:52 EDT
selinux-policy-3.10.0-132.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-132.fc17
Comment 9 Fedora Update System 2012-06-19 20:28:17 EDT
selinux-policy-3.10.0-132.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-07-19 05:16:06 EDT
selinux-policy-3.10.0-132.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.