Bug 827173 - cannot autosubscribe in the gui when partially subscribed
cannot autosubscribe in the gui when partially subscribed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: beta
: 7.0
Assigned To: Carter Kozak
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-05-31 15:55 EDT by J.C. Molet
Modified: 2014-06-17 20:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:29:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partial-auto (216.81 KB, image/png)
2012-05-31 16:00 EDT, J.C. Molet
no flags Details
What's wrong with this picture? (55.89 KB, image/png)
2012-08-02 16:55 EDT, John Sefler
no flags Details
partial-auto-bind (1.43 MB, image/png)
2013-11-08 13:19 EST, Sharath Dwaral
no flags Details

  None (edit)
Description J.C. Molet 2012-05-31 15:55:29 EDT
Description of problem:
When partially subscribed, you cannot use the auto-subscribe feature at all in the gui even though you should be able to.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.19-1.git.0.99a87e8.el6.x86_64
python-rhsm-0.99.12-1.git.1.6f89979.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. set up your product cert dir with a product that has associated subscriptions that are multi-subscribable/stackable
2. set your cpu.cpu_socket(s) to a number greater than those subscriptions provide
3. subscribe to one of those subscriptions in a way that you are only partially subscribed
4. in the subscription-manager-gui, click on "Auto-subscribe"

**NOTE: providing specific replication in following comment.
  
Actual results:
See screen shot.

You get an error saying that you are in full compliance.

Expected results:
You are allowed to auto-subscribe as normal.

Additional info:
Comment 2 J.C. Molet 2012-05-31 16:00:44 EDT
Created attachment 588184 [details]
partial-auto

screen shot
Comment 4 RHEL Product and Program Management 2012-06-04 01:47:48 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Devan Goodwin 2012-06-08 12:31:20 EDT
While opening up the wizard to run when in yellow state, we quickly hit problems with what to do if the system has no SLA preference set, and the wizard tries to get them to choose one. 

Previously logic was a valid SLA is any which provides access to all red products.

Clearly this doesn't work if we only have yellow products. It's also complicated because we shouldn't choose an SLA if it has no bearing on the SLA of existing entitlements.

Decision made to alter the behavior for the more generic situation where we have no SLA set on the system, but there are existing entitlements. (i.e. we're yellow, or we're red but have some products green) 

In this situation, we will check the existing entitlements for their SLAs, ignoring any which have no SLA. 

If there is only one SLA present, we will assume we can use this, set it on the system, and proceed as if they had selected it.

If multiple SLAs are present on current entitlements, we will error out, they must manually subscribe.

If no SLAs are present (i.e. all entitlements do not have an SLA), we assume this system should have no SLA, and do a normal non-SLA autobind as if from the CLI.

As requested in the bug, the autosub wizard should be allowed to run when in overall yellow state.

The user should never be prompted to choose an SLA if they have existing entitlements.


Currently the situation described in this bug can be worked around via the normal healing mechanism, or via the CLI autosubscribe. Because of the scope of the fix required, we will not pursue this fix for 6.3.z.
Comment 6 John Sefler 2012-08-02 16:55:45 EDT
Created attachment 602019 [details]
What's wrong with this picture?

This bug continues to be present in rhel59 and was re-discovered during a Test Day focused on entitlement stacking.

[root@jsefler-rhel59 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.0.11-1.git.11.4d6cb5a.el5
Comment 9 Carter Kozak 2013-09-09 11:31:32 EDT
I threw in a patch for this a while back, should work as expected now.
Comment 11 Sharath Dwaral 2013-11-08 13:19:19 EST
Created attachment 821735 [details]
partial-auto-bind

Version

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.31-1
subscription-manager: 1.10.6-1.el7
python-rhsm: 1.10.6-1.el7

Before Auto-Bind

# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Multi-Attribute Stackable (2 sockets)
Provides:          Multi-Attribute Limited Product
SKU:               sock2-multiattr
Contract:          2
Account:           12331131231
Serial:            7897029266099970173
Pool ID:           8a8d01e04238017101423801f34b0664
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      Level 3
Status Details:    Only covers 2 of 20 sockets.
Starts:            11/07/2013
Ends:              11/07/2014
System Type:       Physical


After Auto-Bind

# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Multi-Attribute Stackable (2 sockets)
Provides:          Multi-Attribute Limited Product
SKU:               sock2-multiattr
Contract:          2
Account:           12331131231
Serial:            7897029266099970173
Pool ID:           8a8d01e04238017101423801f34b0664
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      Level 3
Status Details:    
Starts:            11/07/2013
Ends:              11/07/2014
System Type:       Physical

Subscription Name: Multi-Attribute Stackable (2 sockets)
Provides:          Multi-Attribute Limited Product
SKU:               sock2-multiattr
Contract:          3
Account:           12331131231
Serial:            8305956965275179001
Pool ID:           8a8d01e04238017101423801f26a061b
Active:            True
Quantity Used:     9
Service Level:     Premium
Service Type:      Level 3
Status Details:    
Starts:            11/07/2013
Ends:              11/07/2014
System Type:       Physical


Also see attachment for GUI verification


VERIFIED
Comment 12 Ludek Smid 2014-06-13 05:29:47 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.