Bug 827176 - Current nxagent version 3.5 not supported by FreeNX (Fix included)
Current nxagent version 3.5 not supported by FreeNX (Fix included)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 16:12 EDT by Christian Ziemski
Modified: 2012-06-25 20:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.3-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 12:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Ziemski 2012-05-31 16:12:11 EDT
The nx / freenx-server combination included in Fedora 17 isn't working initially:

Starting /usr/libexec/nx/nxsetup gives the error:

Error: Could not find 1.5.0 or 2.[01].0 or 3.[0123].0 version string in nxagent. NX 1.5.0 or 2.[01].0 or 3.[0123].0 backend is needed for this version of FreeNX.


By fixing the version check in file /usr/libexec/nx/nxloadconfig in lines 675 and 676 by appending "45" three times made freenx-server working again.

These are the fixed lines:

      [ -z "$(strings $COMMAND_NXAGENT | egrep 'NXAGENT - Version 1.5.0|NXAGENT - Version 2.[01].0|NXAGENT - Version 3.[012345].0')" ] && \
              WARNING="yes" && echo "Error: Could not find 1.5.0 or 2.[01].0 or 3.[012345].0 version string in nxagent. NX 1.5.0 or 2.[01].0 or 3.[012345].0 backend is needed for this version of FreeNX."



Christian
Comment 1 Ville Skyttä 2012-06-01 17:17:17 EDT
Please note that the "Error: Could not find ..." message from nxloadconfig is just a warning (even though it says "Error"), and silencing it should not have any other effects nor anything to do with whether nx/freenx-server actually works.  Are you sure that silencing them actually fixes something in your setup besides just getting rid of the messages?

I'm running the versions shipped with F-17/rawhide on F-16 myself and they work fine for me.  I'm not against silencing the warnings per se, but it's been like this at least since 2010 when we updated to 3.4.0 and nobody has reported a problem with them.
Comment 2 Christian Ziemski 2012-06-02 02:29:13 EDT
Today I can't remember if  I even tried to use nx regardless of that Error message. I'm used to see Errors as "Stop" and Warnings as "Continue".

The system in question is located in company - so I'll retry and check that on Monday and let you know the results then.
Comment 3 Ville Skyttä 2012-06-04 12:17:33 EDT
In any case, I don't think the message does any good so hushed in 0.7.3-26 (Rawhide only, not planning to push to other distros just because of this).
Comment 4 Christian Ziemski 2012-06-05 15:29:26 EDT
I checked the system again now.
You are right. It is only an error message, not a real failure. 
I should have looked more closely before reporting a "bug".
Next time I will!
Comment 5 Fedora Update System 2012-06-17 07:16:31 EDT
freenx-server-0.7.3-27.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freenx-server-0.7.3-27.fc17
Comment 6 Fedora Update System 2012-06-25 20:46:36 EDT
freenx-server-0.7.3-27.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.