Bug 827177 - duplicate v7 call home submit command will create duplicate results without matching md5sums
duplicate v7 call home submit command will create duplicate results without m...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Zhiyou Liu
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-05-31 16:18 EDT by Rob Landry
Modified: 2012-06-05 17:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
documentbase patch adding -n to gzip (429 bytes, patch)
2012-05-31 16:20 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2012-05-31 16:18:19 EDT
Description of problem:

Running submit twice back to back without any test runs or other changes to the results will upload to the catalog even though it is duplicate.


Version-Release number of selected component (if applicable):
v7-1.5-30

How reproducible:
Everytime

Steps to Reproduce:
1.run v7 and test something
2.run v7 submit, send to catalog but do not remove results
3.run v7 submit, send to catalog
  
Actual results:
v7 is allowed to upload the same results twice


Expected results:
catalog should return an error because the results are the same

Additional info:
This is a side effect of using gzip including the timestamp on results.xml as part of the submit.  Passing the "-n" parameter to gzip will have it ignore the current time which results in the xml.gz package with the same test results content having the same md5sum.
Comment 1 Greg Nichols 2012-05-31 16:20:56 EDT
Created attachment 588186 [details]
documentbase patch adding -n to gzip
Comment 7 Caspar Zhang 2012-06-04 04:11:43 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 9 errata-xmlrpc 2012-06-05 17:30:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.