This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 827181 - SELinux is preventing /usr/bin/perl from 'read' accesses on the file utils.pm.
SELinux is preventing /usr/bin/perl from 'read' accesses on the file utils.pm.
Status: CLOSED DUPLICATE of bug 827179
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ae135bf8b12107b0aeb671f0078...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 16:23 EDT by Raman Gupta
Modified: 2012-05-31 16:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 16:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2012-05-31 16:23:33 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/perl from 'read' accesses on the file utils.pm.
time:           Thu 31 May 2012 04:23:17 PM EDT

description:
:SELinux is preventing /usr/bin/perl from 'read' accesses on the file utils.pm.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that perl should be allowed read access on the utils.pm file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep check_linux_rai /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:nagios_checkdisk_plugin_t:s0
:Target Context                system_u:object_r:bin_t:s0
:Target Objects                utils.pm [ file ]
:Source                        check_linux_rai
:Source Path                   /usr/bin/perl
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           perl-5.14.2-197.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.x86_64 #1 SMP Tue May 22
:                              13:59:39 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Thu 31 May 2012 04:20:11 PM EDT
:Last Seen                     Thu 31 May 2012 04:22:37 PM EDT
:Local ID                      053bc7cb-aff0-487e-99a3-2b5dde0f19a2
:
:Raw Audit Messages
:type=AVC msg=audit(1338495757.144:1502): avc:  denied  { read } for  pid=12490 comm="check_linux_rai" name="utils.pm" dev="dm-0" ino=3018065 scontext=system_u:system_r:nagios_checkdisk_plugin_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338495757.144:1502): arch=x86_64 syscall=open success=no exit=EACCES a0=1f65e80 a1=0 a2=1b6 a3=3c6352e550 items=0 ppid=12489 pid=12490 auid=4294967295 uid=993 gid=990 euid=993 suid=993 fsuid=993 egid=990 sgid=990 fsgid=990 tty=(none) ses=4294967295 comm=check_linux_rai exe=/usr/bin/perl subj=system_u:system_r:nagios_checkdisk_plugin_t:s0 key=(null)
:
:Hash: check_linux_rai,nagios_checkdisk_plugin_t,bin_t,file,read
:
:audit2allow
:
:#============= nagios_checkdisk_plugin_t ==============
:allow nagios_checkdisk_plugin_t bin_t:file read;
:
:audit2allow -R
:
:#============= nagios_checkdisk_plugin_t ==============
:allow nagios_checkdisk_plugin_t bin_t:file read;
:
Comment 1 Raman Gupta 2012-05-31 16:36:17 EDT

*** This bug has been marked as a duplicate of bug 827179 ***

Note You need to log in before you can comment on or make changes to this bug.