Bug 827191 - Cannot dismiss rhsm-icon pop up dialog
Cannot dismiss rhsm-icon pop up dialog
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-05-31 16:52 EDT by J.C. Molet
Modified: 2014-01-03 15:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 15:14:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
notifications (560.61 KB, image/png)
2012-05-31 16:52 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-05-31 16:52:28 EDT
Description of problem:
When you unsubscribe from any subscriptions while you are fully compliant, you get a black pop up dialog from the rhsm-icon telling you about your change in compliance status.  You cannot click the X button or in the black area to dismiss this.

Version-Release number of selected component (if applicable):
subscription-manager-0.99.19-1.git.0.99a87e8.el6.x86_64
subscription-manager-migration-data-1.12.1.8-1.git.0.c91a246.el6.noarch
subscription-manager-gnome-0.99.19-1.git.0.99a87e8.el6.x86_64
subscription-manager-migration-0.99.19-1.git.0.99a87e8.el6.x86_64
subscription-manager-firstboot-0.99.19-1.git.0.99a87e8.el6.x86_64
python-rhsm-0.99.12-1.git.1.6f89979.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Install a Spankin' Fresh (TM) copy of subscription manager on RHEL6.3
2. Register, and become fully compliant (to simplify things I used a single 69.pem product and a single subscription)
3. Open the subscription-manager-gui
4. Unregister from something using the GUI, or use subscription-manager unsubscribe --all

  
Actual results:
- You get a status pop-up/notification that you can dismiss but only pops up over and over until the timer runs out.

- Sometimes you get two notifications showing at once when you try to close one.

- You get a notification even if the GUI is already up.

Expected results:
1) If you click the X on the notification, It goes away for good (until another status change)

2) If you click anywhere in the black or main face of the notification it pops up subscription-manager-gui and goes away for good (this is a regression - it used to work this way)

3) If the GUI is already open, you do not get a notification at all.  The GUI itself lets you know your status already and its redundant.

Additional info:
Comment 1 J.C. Molet 2012-05-31 16:52:53 EDT
Created attachment 588194 [details]
notifications
Comment 3 RHEL Product and Program Management 2012-06-04 01:47:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 James Bowes 2012-06-08 11:36:10 EDT
I haven't been able to reproduce point 1 and 2 at all.

Point 3 is valid, but since its not a regression and will take a bit of work, I say we postpone it for 5.9.

JC, are you still able to reproduce this? I'm using the nightly built on May 30:

]# rpm -q subscription-manager python-rhsm
subscription-manager-0.99.19-1.el6.x86_64
python-rhsm-0.99.12-1.el6.noarch
Comment 5 James Bowes 2012-06-11 12:11:48 EDT
Moving to 5.9 as discussed on the mailing list
Comment 6 RHEL Product and Program Management 2012-06-11 12:28:15 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 RHEL Product and Program Management 2012-12-14 03:47:31 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 Carter Kozak 2013-10-30 14:40:35 EDT
I think this is a notification-daemon problem, but it doesn't appear to occur in rhel7, do you think we can close it out?
Comment 11 Bryan Kearney 2014-01-03 15:14:46 EST
Closing per comment 10.

Note You need to log in before you can comment on or make changes to this bug.