Bug 827218 - Cheese seems to have trouble with Logitech c525 HD webcam
Cheese seems to have trouble with Logitech c525 HD webcam
Status: CLOSED DUPLICATE of bug 815581
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 18:09 EDT by Aram Agajanian
Modified: 2012-06-06 07:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 07:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2012-05-31 18:09:17 EDT
Description of problem:
I have a Logitech c525 HD webcam.

When I start Cheese, it takes about 30 seconds to start.  Once Cheese has started, the video looks OK and it seems responsive.

If I try to take a photo, it seems to work but no photo appears in the bottom area of the window.

If I try to record a video, Cheese's UI stops responding.  I see the following messages printed to stdout.  I can still exit Cheese by clicking on the X button in the titlebar.  (It takes a while for it to close as well.)

** (cheese:9093): WARNING **: Could not get buffers from device '/dev/video0'.


** (cheese:9093): WARNING **: Could not map buffers from device '/dev/video0'


** (cheese:9093): WARNING **: Could not negotiate format


** (cheese:9093): WARNING **: Could not get buffers from device '/dev/video0'.


** (cheese:9093): WARNING **: Could not map buffers from device '/dev/video0'


** (cheese:9093): WARNING **: Could not negotiate format

libv4l2: error setting pixformat: Device or resource busy

** (cheese:9093): WARNING **: Device '/dev/video0' is busy


** (cheese:9093): WARNING **: Could not negotiate format


Version-Release number of selected component (if applicable):
cheese-3.4.1-1.fc17.x86_64

How reproducible:
Happens every time.

Steps to Reproduce:
1. Start Cheese.
2. Click on the Video tab.
3. Click on the button labeled "Record a Video".
  
Actual results:
The UI becomes unresponsive.

Expected results:
The UI should continue to be responsive and Cheese should start recording a video.

Additional info:
Bus 002 Device 010: ID 046d:0826 Logitech, Inc.
Comment 1 Hans de Goede 2012-06-06 06:02:36 EDT
Hi,

Does the video preview work when you're not trying to record a video ?

Also when you try to record a video does anything show up in the output of the "dmesg" command ?

Regards,

Hans
Comment 2 Hans de Goede 2012-06-06 07:11:47 EDT

*** This bug has been marked as a duplicate of bug 815581 ***

Note You need to log in before you can comment on or make changes to this bug.