Bug 827232 - Logrotate for clamsmtp attempts to kill non-existent process
Logrotate for clamsmtp attempts to kill non-existent process
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clamsmtp (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nathanael Noblet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 18:45 EDT by Bojan Smojver
Modified: 2012-07-05 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 19:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2012-05-31 18:45:28 EDT
Description of problem:
The script has:
----------------
pkill -SIGHUP -f clamd.clamsmtp 2>/dev/null || :
----------------

There is no such process. Only this:
----------------
/usr/sbin/clamsmtpd -f /etc/clamsmtpd.conf -p /run/clamsmtpd/clamsmtpd.pid
----------------

Version-Release number of selected component (if applicable):
clamsmtp-1.10-8.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Wait for montly log rotation or do it by hand.
2. Get:
----------------
error: error running non-shared postrotate script for /var/log/clamd.clamsmtp/clamsmtpd.log of '/var/log/clamd.clamsmtp/clamsmtpd.log '
----------------

Actual results:
Error, most likely caused by pkill not matching any processes.

Expected results:
Should HUP the process properly (the manual of clamsmtpd doesn't mention HUP at all, but let's be optimistic).

Additional info:
Comment 1 Fedora Update System 2012-06-01 02:28:29 EDT
clamsmtp-1.10-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/clamsmtp-1.10-9.fc17
Comment 2 Fedora Update System 2012-06-26 17:39:43 EDT
Package clamsmtp-1.10-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clamsmtp-1.10-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9961/clamsmtp-1.10-9.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-07-05 19:28:52 EDT
clamsmtp-1.10-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.