Bug 827270 - AttributeError: 'NoneType' object has no attribute 'endswith'
AttributeError: 'NoneType' object has no attribute 'endswith'
Status: CLOSED DUPLICATE of bug 826698
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:ee1815bf56dd9cbb1cf469b6f5d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 21:20 EDT by Steve Grubb
Modified: 2013-01-10 01:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 21:27:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-Armojn (532.07 KB, text/plain)
2012-05-31 21:20 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2012-05-31 21:20:27 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-Armojn
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Fri 01 Jun 2012 01:19:05 AM UTC
version:        17

anaconda-tb-Armojn: Text file, 544838 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 3492, in path
:    while mountpoint.endswith("/"):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 918, in _setFormat
:    format = getFormat(None, device=self.path, exists=self.exists)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 932, in <lambda>
:    lambda d,f: d._setFormat(f),
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 481, in __init__
:    self.format = format
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 3470, in __init__
:    exists=exists, parents=parents)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1990, in _parseOneLine
:    device = DirectoryDevice(devspec, parents=parents, exists=True)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2112, in parseFSTab
:    device = self._parseOneLine((devspec, mountpoint, fstype, options, dump, passno))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1676, in mountExistingSystem
:    fsset.parseFSTab(anaconda=anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 178, in upgradeMountFilesystems
:    mountExistingSystem(anaconda, anaconda.upgradeRoot[0], allowDirty = 0)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:AttributeError: 'NoneType' object has no attribute 'endswith'

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.o1ZwBV
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Steve Grubb 2012-05-31 21:20:45 EDT
Created attachment 588228 [details]
File: anaconda-tb-Armojn
Comment 2 Jesse Keating 2012-05-31 21:27:37 EDT

*** This bug has been marked as a duplicate of bug 826698 ***

Note You need to log in before you can comment on or make changes to this bug.