Bug 827309 - ONBOOT parameter doesn't change to no after disable network.
ONBOOT parameter doesn't change to no after disable network.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 01:42 EDT by cshao
Modified: 2016-04-26 10:49 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
Disabling a network using the hypervisor text user interface did not change the onboot parameter in the corresponding /etc/sysconfig/network-scripts/* file, so the network was not disabled properly. Now, all network scripts are reset before new ones are configured, so networks can be disabled properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:35:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2012-06-01 01:42:50 EDT
Description of problem:
ONBOOT parameter doesn't change to no after disable network.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. TUI install RHEV-H and configure network with dhcp.
2. Enter network menu and disable network.
3. Execute command "ifconfig".
  
Actual results:
1. breth0 & eth0 still show after disable network.
2. ONBOOT parameter doesn't change to no after disable network.

# cat /etc/sysconfig/network-scripts/ifcfg-breth0 | grep ONBOOT
ONBOOT=yes

# cat /etc/sysconfig/network-scripts/ifcfg-eth0 | grep ONBOOT
ONBOOT=yes

Expected results:
ONBOOT=no after disable network.

Additional info:
Comment 4 RHEL Product and Program Management 2012-07-10 01:55:51 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:50:17 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Mike Burns 2012-07-13 14:02:36 EDT
Low prio, but should be fairly simple.  When disable network, we should do the same process we do before configuring a new network interface.  We reset all network scripts, before configuring the new one.

Note:  if we disable a network, we should also make sure the /etc/sysconfig/network sets NETWORK=No
Comment 12 errata-xmlrpc 2013-02-28 11:35:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.