Bug 827315 - Update to v16.14
Update to v16.14
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumed-server (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susmit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 02:14 EDT by Michel Alexandre Salim
Modified: 2012-06-11 20:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 20:28:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff against the package repo for Rawhide (18.71 KB, patch)
2012-06-01 02:14 EDT, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2012-06-01 02:14:23 EDT
Created attachment 588322 [details]
diff against the package repo for Rawhide

Description of problem:
The currently packaged gnumed-server has a bug in its bootstrap script, and is several releases behind the latest available version.

The attached patch updates to v16.14 (the latest available) and fixes a couple of packaging issues; please review.

Version-Release number of selected component (if applicable):
gnumed-server-15.5-3

How reproducible:
Always

Steps to Reproduce:
1. Attempt to run gm-bootstrap_server
  
Actual results:
- script points to wrong path (/usr/lib instead of /var/lib)
- since the bootsrap directory is installed one level less nested than expected,
  the bootstrap process creates the Gnumed symlink in the wrong directory
  and to the wrong target
- Upgrading from v2 to v3 fails with an invalid SQL statement


Expected results:
Bootstrapping works without a problem, no packaging-related issues


Additional info:
Comment 1 Fedora Update System 2012-06-01 23:44:06 EDT
gnumed-server-16.14-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnumed-server-16.14-1.fc15
Comment 2 Fedora Update System 2012-06-01 23:44:16 EDT
gnumed-server-16.14-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnumed-server-16.14-1.fc16
Comment 3 Fedora Update System 2012-06-01 23:44:26 EDT
gnumed-server-16.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnumed-server-16.14-1.fc17
Comment 4 Fedora Update System 2012-06-02 19:55:45 EDT
Package gnumed-server-16.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnumed-server-16.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8786/gnumed-server-16.14-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-11 20:28:10 EDT
gnumed-server-16.14-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-06-11 20:32:09 EDT
gnumed-server-16.14-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-06-11 20:37:34 EDT
gnumed-server-16.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.