Bug 827322 - Caught Error when visiting the url of drupal template application.
Caught Error when visiting the url of drupal template application.
Status: CLOSED DUPLICATE of bug 827281
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 02:27 EDT by Yujie Zhang
Modified: 2015-05-14 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 04:18:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-06-01 02:27:59 EDT
Description of problem:

I created a drupal template application, and tried to visit the url of the application, caught the following error.

Version-Release number of selected component (if applicable):

int.openshift.redhat.com

How reproducible:

always

Steps to Reproduce:
1.Go to openshift and login
2.Create drupal template application
3.Try to visit the url of this application
  
Actual results:

I caught the following error:

Notice: Undefined index: OPENSHIFT_DB_USERNAME in include_once() (line 186 of /var/lib/stickshift/88a741f3f9534f2ea33609c86f0a14bc/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_PASSWORD in include_once() (line 187 of /var/lib/stickshift/88a741f3f9534f2ea33609c86f0a14bc/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_HOST in include_once() (line 188 of /var/lib/stickshift/88a741f3f9534f2ea33609c86f0a14bc/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_PORT in include_once() (line 189 of /var/lib/stickshift/88a741f3f9534f2ea33609c86f0a14bc/app-root/runtime/repo/php/sites/default/settings.php).
    PDOException: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in lock_may_be_available() (line 164 of /var/lib/stickshift/88a741f3f9534f2ea33609c86f0a14bc/app-root/runtime/repo/php/includes/lock.inc).


Expected results:

The page of drupal template application should be correct.

Additional info:
Comment 1 Xiaoli Tian 2012-06-01 04:18:37 EDT

*** This bug has been marked as a duplicate of bug 827281 ***

Note You need to log in before you can comment on or make changes to this bug.