Bug 827334 - gfid is not there in the fsetattr and rchecksum requests being sent from protocol client
gfid is not there in the fsetattr and rchecksum requests being sent from prot...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Amar Tumballi
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 03:19 EDT by Raghavendra Bhat
Modified: 2018-03-15 07:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-15 07:27:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-06-01 03:19:26 EDT
Description of problem:
Protocol client is not sending the gfid of the file when the fop is fsetattr or rchecksum.

struct gfs3_fsetattr_req {
        quad_t fd;
        struct gf_iatt stbuf;
        int valid;
        struct {
                u_int xdata_len;
                char *xdata_val;
	} xdata;
};
typedef struct gfs3_fsetattr_req gfs3_fsetattr_req;

struct gfs3_rchecksum_req {
        quad_t fd;
        u_quad_t offset;
        u_int len;
        struct {
                u_int xdata_len;
                char *xdata_val;
        } xdata;
};
typedef struct gfs3_rchecksum_req gfs3_rchecksum_req;



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
gfid is not sent to protocol server in the request structure for fsetattr amd rcheckdum.

Expected results:

gfid is sent with all other fd based fops.

Additional info:
Comment 1 Amar Tumballi 2012-10-11 09:15:20 EDT
http://review.gluster.org/3956
Comment 2 Niels de Vos 2013-01-02 11:45:07 EST
When this gets accepted, please also file a Bug at bugs.wireshark.org, or let me
know and I'll look into extending the glusterfs dissectors.
Comment 3 Anand Avati 2013-08-09 12:26:52 EDT
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#2) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 4 Anand Avati 2013-08-19 14:24:50 EDT
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#3) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 5 Anand Avati 2013-09-23 05:08:43 EDT
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#4) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 6 Anand Avati 2013-09-25 05:52:11 EDT
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#5) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 7 Anand Avati 2013-11-10 02:45:55 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#6) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 8 Anand Avati 2013-11-14 02:23:23 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#7) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 9 Anand Avati 2013-11-14 02:43:03 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#8) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 10 Anand Avati 2013-11-14 03:22:48 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#9) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 11 Anand Avati 2013-11-14 03:26:39 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#10) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 12 Anand Avati 2013-11-27 00:47:57 EST
REVIEW: http://review.gluster.org/3956 (protocol: add gfid to on wire format for fsetattr/rchecksum) posted (#12) for review on master by Amar Tumballi (amarts@gmail.com)
Comment 15 Kaleb KEITHLEY 2015-10-22 11:46:38 EDT
because of the large number of bugs filed against mainline version\ is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.
Comment 16 Worker Ant 2017-06-30 05:21:27 EDT
REVIEW: https://review.gluster.org/17656 (protocol: bring new version) posted (#1) for review on experimental by Amar Tumballi (amarts@redhat.com)
Comment 17 Worker Ant 2017-07-03 13:37:23 EDT
COMMIT: https://review.gluster.org/17656 committed in experimental by Amar Tumballi (amarts@redhat.com) 
------
commit 73d944d627bf747e2e3117b434d685b350c8b816
Author: Amar Tumballi <amarts@redhat.com>
Date:   Fri Jun 30 13:12:22 2017 +0530

    protocol: bring new version
    
    Change-Id: Icaf8c027d04e142f2d36ae7df75c4aae5b21325f
    BUG: 827334
    Signed-off-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-on: https://review.gluster.org/17656
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 18 Worker Ant 2017-10-24 09:43:59 EDT
REVIEW: https://review.gluster.org/3956 (rpc: bring a new protocol version) posted (#13) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 19 Worker Ant 2017-11-07 02:54:25 EST
COMMIT: https://review.gluster.org/3956 committed in master by  

------------- rpc: bring a new protocol version

* xdr: add gfid to on wire format for fsetattr/rchecksum
* as it is change in on wire XDR format, needed backward
  compatible RPC programs.

Signed-off-by: Amar Tumballi <amarts@redhat.com>
BUG: 827334
Change-Id: Id0a2da3632516dc1a5560dde2b151b2e5f0be8e5
Comment 20 Shyamsundar 2018-03-15 07:27:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.