Bug 827358 - "Failed to read image" info show in grub if installed RHEV-H via livecd.
"Failed to read image" info show in grub if installed RHEV-H via livecd.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 04:34 EDT by cshao
Modified: 2014-01-21 14:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An error message "Failed to read image" was shown in grub if installing the hypervisor via livecd. This problem was solved in version 6.4 and no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:15:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed to read image (18.67 KB, image/jpeg)
2012-06-01 04:34 EDT, cshao
no flags Details

  None (edit)
Description cshao 2012-06-01 04:34:45 EDT
Created attachment 588355 [details]
failed to read image

Description of problem:
"Failed to read image" info show in grub if installed RHEV-H via livecd.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Make livecd to usb via command "rhevh-iso-to-disk --format /usr/share/rhev-hypeisor/rhevh-6.3-20120531.0.iso /dev/sdb".
2. Boot from the livecd and install RHEV-H.
3. Reboot host and focus on grub menu.
  
Actual results:
1. Initializing Intel(R) Boot Agent GE v1.3.52.1
PXE 2.1 Build 089 (WFM 2.0)
failed to read image
Press any key to enter the menu.
2. Install RHEV-H via PXE no such issue.
3. Boot to RHEV-H can successful.

Expected results:
No error info show in grub.

Additional info:
Comment 3 Mike Burns 2012-06-01 08:01:02 EDT
this looks purely cosmetic and though it wasn't there in 6.2, I don't think this is a blocker, deferring to 6.4
Comment 6 Mike Burns 2012-07-11 09:28:05 EDT
Is this still seen in latest rhev-h 6.3?  Looking at the screen shot, it looks like it's failing to load the pxe image, isn't it?  You're not booting from PXE, so that's not a problem.
Comment 7 cshao 2012-07-11 22:33:41 EDT
(In reply to comment #6)
> Is this still seen in latest rhev-h 6.3?

1. Still can reproduce this issue with rhev-hypervisor6-6.3-20120710.0.el6_3 build if install RHEV-H via livecd.

>  Looking at the screen shot, it looks like it's failing to load the pxe image, isn't it? 

I agree with you. No such issue if install RHEV-H via PXE, 

> You're not booting from PXE, so that's not a problem.
Comment 8 Mike Burns 2012-07-16 14:54:37 EDT
This appears to be a PXE server issue.  It causes no problem that has been seen.
Comment 18 cshao 2013-10-25 02:51:42 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Make livecd to usb via command "rhevh-iso-to-disk --format /usr/share/rhev-hypeisor/rhevh-*.iso /dev/sdb".
2. Boot from the livecd and install RHEV-H.
3. Reboot host and focus on grub menu.

Test result:
No error info show in grub.

So the bug is fixed, change bug status to VERIFIED.
Comment 20 Cheryn Tan 2013-11-07 19:30:18 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 22 errata-xmlrpc 2014-01-21 14:15:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.