Bug 827396 - cgclassify & "No space left on device" [NEEDINFO]
cgclassify & "No space left on device"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nikola Forró
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 06:56 EDT by Ondrej Valousek
Modified: 2017-12-06 05:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:47:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jchaloup: needinfo? (ondrejv)


Attachments (Terms of Use)

  None (edit)
Description Ondrej Valousek 2012-06-01 06:56:04 EDT
Description of problem:
When limiting CPU resources with "cpu.shares = 100",
cgclassify fails with "No space left on device" unless I have also
cpuset.cpus = 0;
cpuset.mems = 0;
specified.

This is probably wrong (or at least misleading, isn't it?)

Version-Release number of selected component (if applicable):
0.37

How reproducible:
always
Comment 5 RHEL Product and Program Management 2012-12-14 03:09:08 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Peter Schiffer 2013-08-16 09:40:15 EDT
Ondrej,

can you try this build and test it? I can't reproduce this problem..
https://dl.dropboxusercontent.com/u/15321270/libcgroup-0.37-10.el6.x86_64.rpm
https://dl.dropboxusercontent.com/u/15321270/libcgroup-devel-0.37-10.el6.x86_64.rpm
https://dl.dropboxusercontent.com/u/15321270/libcgroup-pam-0.37-10.el6.s390x.rpm
https://dl.dropboxusercontent.com/u/15321270/libcgroup-debuginfo-0.37-10.el6.s390x.rpm

# rpm -q libcgroup
libcgroup-0.37-10.el6.i686

# cat /etc/cgconfig.conf 
# Configuration file generated by cgsnapshot
mount {
	cpuset = /cgroup/cpuset;
	cpu = /cgroup/cpu;
	cpuacct = /cgroup/cpuacct;
	memory = /cgroup/memory;
	devices = /cgroup/devices;
	freezer = /cgroup/freezer;
	net_cls = /cgroup/net_cls;
	blkio = /cgroup/blkio;
}

group limitcpu {
	cpu {
		cpu.shares="100";
	}
}

# cat /cgroup/cpu/limitcpu/cpu.shares 
100

# cgclassify -g cpu:limitcpu $$
# 

Thanks,

peter
Comment 7 Jan Chaloupka 2014-08-04 06:19:16 EDT
ping
Comment 8 Jan Kurik 2017-12-06 05:47:31 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.