Bug 827401 - bind-dyndb-ldap crashes during zone unload when NS is not resolvable
bind-dyndb-ldap crashes during zone unload when NS is not resolvable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind-dyndb-ldap (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 827414 829353
  Show dependency treegraph
 
Reported: 2012-06-01 07:17 EDT by Martin Kosek
Modified: 2013-04-30 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 829353 (view as bug list)
Environment:
Last Closed: 2012-06-19 10:54:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/named.conf (1.29 KB, text/plain)
2012-06-01 07:18 EDT, Martin Kosek
no flags Details
Zones (4.73 KB, text/plain)
2012-06-01 07:20 EDT, Martin Kosek
no flags Details

  None (edit)
Description Martin Kosek 2012-06-01 07:17:23 EDT
Description of problem:
bind-dyndb-ldap crashes during freeipa unit tests (psearch enabled). The root cause is probably an unresolvable NS record zone root record.

Backtrace:
(gdb) bt
#0  0x00007ffff50a0965 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007ffff50a2118 in __GI_abort () at abort.c:91
#2  0x000055555558527b in assertion_failed (file=<optimized out>, line=<optimized out>, 
    type=<optimized out>, cond=<optimized out>) at ./main.c:219
#3  0x00007ffff62bec3a in isc_assertion_failed (file=file@entry=0x7ffff799c47b "zone.c", 
    line=<optimized out>, type=type@entry=isc_assertiontype_require, 
    cond=cond@entry=0x7ffff799c677 "zone->db != ((void *)0)") at assertions.c:57
#4  0x00007ffff79453d7 in zone_detachdb (zone=<optimized out>) at zone.c:12935
#5  zone_detachdb (zone=0x7fffec5bbff0) at zone.c:12934
#6  0x00007ffff7945445 in zone_unload (zone=zone@entry=0x7fffec5bbff0) at zone.c:9105
#7  0x00007ffff7949664 in dns_zone_unload (zone=0x7fffec5bbff0) at zone.c:9045
#8  0x00007ffff249ca8e in ldap_delete_zone2 (inst=inst@entry=0x7ffff7fc9f10, 
    name=name@entry=0x7ffff3ff2d10, lock=lock@entry=isc_boolean_true) at ldap_helper.c:787
#9  0x00007ffff249e414 in ldap_delete_zone (dn=<optimized out>, inst=0x7ffff7fc9f10, 
    lock=<optimized out>) at ldap_helper.c:812
#10 update_action (task=<optimized out>, event=0x7ffff26f6a60) at ldap_helper.c:2749
#11 0x00007ffff62de13e in dispatch (manager=0x7ffff7fa8010) at task.c:1109
#12 run (uap=0x7ffff7fa8010) at task.c:1279
#13 0x00007ffff5c93d14 in start_thread (arg=0x7ffff3ff3700) at pthread_create.c:309
#14 0x00007ffff515c99d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Zone LDIF is attached.

Version-Release number of selected component (if applicable):
bind-dyndb-ldap-1.1.0-0.10.b2.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Use attached LDIF to create a zone
2. Run named
3.
  
Actual results:
bind-dyndb-ldap crashes with zone with this LDIF

Expected results:
bind-dyndb-ldap does not crash

Additional info:
Comment 1 Martin Kosek 2012-06-01 07:18:27 EDT
Created attachment 588407 [details]
/etc/named.conf
Comment 2 Martin Kosek 2012-06-01 07:20:27 EDT
Created attachment 588408 [details]
Zones
Comment 3 Petr Spacek 2012-06-05 11:31:18 EDT
I can't reproduce it with given LDIF. Please provide exact BIND version and your /etc/named.conf.
Comment 4 Martin Kosek 2012-06-05 11:39:46 EDT
I attached /etc/named.conf to this ticket. I can always reproduce this issue when running FreeIPA DNS unit tests and have psearch enabled.

bind version: bind-9.9.1-2.P1.fc17.x86_64
Comment 5 Petr Spacek 2012-06-06 09:50:55 EDT
Upstream ticket:
https://fedorahosted.org/bind-dyndb-ldap/ticket/77
Comment 6 Fedora Update System 2012-06-07 11:48:49 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-1.1.0-0.12.rc1.fc16
Comment 7 Fedora Update System 2012-06-07 11:49:04 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-1.1.0-0.12.rc1.fc15
Comment 8 Fedora Update System 2012-06-07 11:49:38 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-1.1.0-0.12.rc1.fc17
Comment 9 Fedora Update System 2012-06-08 19:58:37 EDT
Package bind-dyndb-ldap-1.1.0-0.12.rc1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind-dyndb-ldap-1.1.0-0.12.rc1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9102/bind-dyndb-ldap-1.1.0-0.12.rc1.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-06-19 10:54:51 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-06-19 11:10:58 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-06-19 11:12:05 EDT
bind-dyndb-ldap-1.1.0-0.12.rc1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.