Bug 827408 - netconsole doesn't work after configured in TUI
netconsole doesn't work after configured in TUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 07:43 EDT by yuanquan chen
Modified: 2016-04-26 09:43 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
The netconsole service was not enabled by default, therefore console log messages were not automatically forwarded from the hypervisor to a configured remote host. Netconsole is now enabled by default, and all messages above the threshold specified in /proc/sys/kernel/printk are forwarded.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:35:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuanquan chen 2012-06-01 07:43:30 EDT
Description of problem:
Configure the netconsole service in TUI, but it doesn't work.

After configuring the netconsole server ip and port as 6666 and execute the "nc -l -u 6666" on the configured receiver, do something to cause kernel printk message, such as "echo hello > /dev/kmsg",  insert some kernel module and so on. But the receiver can't get any kernel message from the rhev-h host. I check the /proc/sys/kernel/printk, the value is 1, change it to 7, then the receiver can get the kernel message of the rhev-h host.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6


How reproducible:
100%

Steps to Reproduce:
1. install rhev-h and boot up
2. configure the netconsole server and port, apply it
3. use "nc -l -u 6666(the port you set)" to monitor the console message forwarded by rhev-h
4. "echo hello > /dev/kmsg" or insert some kernel module in rhev-h, see the output of "nc -l -u 6666" on the receiver
  
Actual results:
The receiver can't get any kernel message forwarded from rhev-h host. While the /proc/sys/kernel/printk value is 1 by default, change it to 7, the receiver can get the kernel message of rhev-h host


Expected results:
After configuring the netconsole service in TUI, the receiver can get the kernel message of rhev-h host directly, no need to change the printk value

Additional info:
Comment 2 Fabian Deutsch 2012-06-04 05:56:28 EDT
netconsoles purpose is to send all _console log messages_ via UDP to a remote host. And that seems to be working.

/proc/sys/kernel/printk defines the threshold what messages go to the console (and therefor netconsole too). 
The examples you gave above (echo abc > /dev/kmsg) are just not above the threshold and therefor not displayed on the console and send to the remote server, but logged to dmesg (which has a lower threshold).

syslog is the way to go to receive everything that goes to dmesg (AFAIK)
Comment 3 Fabian Deutsch 2012-06-04 06:12:13 EDT
This patch fixes a side problem: Netconsole is not enabled by default.

http://gerrit.ovirt.org/5027
Comment 10 errata-xmlrpc 2013-02-28 11:35:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.