Bug 827448 - Add small-dict optimization
Add small-dict optimization
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jeff Darcy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 09:58 EDT by Jeff Darcy
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:38:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2012-06-01 09:58:39 EDT
Dicts are being used more and more in our I/O path (e.g. for xdata) so performance is a significant concern and our current implementation allocates data_pair structures separately from the dict itself.  Since many dicts are used to hold a very small number of items - often just one - we can optimize by allocating the first data_pair as part of the dict structure.
Comment 1 Amar Tumballi 2012-08-05 14:48:31 EDT
http://review.gluster.com/3040 is commited to master branch

Note You need to log in before you can comment on or make changes to this bug.