Bug 827453 - FTBFS: *** glibc detected *** /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.ppc64/jre/bin/java: invalid fastbin entry (free): 0x00000ffea801a7c0
FTBFS: *** glibc detected *** /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.ppc64/...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 10:08 EDT by Karsten Hopp
Modified: 2012-12-18 15:04 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 15:04:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
build.log, just in case koji deletes the log after a certain time (791.21 KB, text/plain)
2012-06-01 10:09 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2012-06-01 10:08:11 EDT
Description of problem:
eclipse-4.2.0-0.20.I201205031800.fc18 fails to build on PPC64:

     [java]     [javac] Compiling 36 source files to /builddir/build/BUILD/eclipse-build-d747eda66dae13c133f56952466ff0ca30da99bf/build/eclipse-4.2.0-I20120503-1800-src/plugins/org.eclipse.core.runtime.compatibility/@dot
     [java] *** glibc detected *** /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.ppc64/jre/bin/java: invalid fastbin entry (free): 0x00000ffea801a7c0 ***
     [java] *** glibc detected *** /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.ppc64/jre/bin/java: malloc(): memory corruption (fast): 0x00000ffea801a7d0 ***
     [java] ======= Backtrace: =========



Steps to Reproduce:
1. ppc-koji build --scratch f18 eclipse-4.2.0-0.20.I201205031800.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=574490
Comment 1 Karsten Hopp 2012-06-01 10:09:38 EDT
Created attachment 588474 [details]
build.log, just in case koji deletes the log after a certain time
Comment 2 Alexander Kurtakov 2012-06-01 10:18:55 EDT
Reassigning to openjdk as it's a jvm crash happening on ppc only
Comment 3 Deepak Bhole 2012-06-01 11:44:05 EDT
Assigning to Chris. Chris, looks like a PPC specific crash. Can you please take a look?
Comment 4 Chris Phillips @ TO 2012-06-01 13:58:47 EDT
Is there a hs_err_pid*log somewhere for this?
Is it repeatable ?

Thanks for any info... (There are a ton of problems with zip/jar files being read while also being written... but can't tell if thats whats going on here.)
Comment 5 Deepak Bhole 2012-10-23 14:52:51 EDT
This appears to be the same issue as with 560232

There is unfortunately not much the JVM can do here as memory mapping provides a significant performance advantage. If applications expect loaded jar/zip files to change, they should supply the -Dsun.zip.disableMemoryMapping=true switch to the appropriate java invocation. Therefore the fix for this is to add -Dsun.zip.disableMemoryMapping=true in the build.xml file for the java task that is failing.

Switching component to Eclipse.
Comment 6 Alexander Kurtakov 2012-12-18 15:04:20 EST
Closing the bug as eclipse builds no longer trigger the ppc crash.

Note You need to log in before you can comment on or make changes to this bug.