Bug 827488 - [abrt] evolution-3.4.1-2.fc17: e_ews_folder_get_folder_type: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.1-2.fc17: e_ews_folder_get_folder_type: Process /usr/bin...
Status: CLOSED DUPLICATE of bug 787514
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:9837da32f28c3f0d3eced4bc8b0...
:
: 839910 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 11:24 EDT by Kenneth Brown
Modified: 2012-07-16 12:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 05:59:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.05 KB, text/plain)
2012-06-01 11:24 EDT, Kenneth Brown
no flags Details
File: gconf_subtree (9.75 KB, text/plain)
2012-06-01 11:24 EDT, Kenneth Brown
no flags Details
File: maps (89.02 KB, text/plain)
2012-06-01 11:24 EDT, Kenneth Brown
no flags Details
File: dso_list (18.20 KB, text/plain)
2012-06-01 11:24 EDT, Kenneth Brown
no flags Details
File: build_ids (7.41 KB, text/plain)
2012-06-01 11:24 EDT, Kenneth Brown
no flags Details

  None (edit)
Description Kenneth Brown 2012-06-01 11:24:29 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
comment:        Occurs when opening evolution
crash_function: e_ews_folder_get_folder_type
executable:     /usr/bin/evolution
kernel:         3.3.7-1.fc17.x86_64
pid:            27462
pwd:            /home/kennet4
time:           Fri 01 Jun 2012 11:16:07 AM EDT
uid:            1000
username:       kennet4
xsession_errors: 

backtrace:      Text file, 43055 bytes
build_ids:      Text file, 7585 bytes
dso_list:       Text file, 18636 bytes
gconf_subtree:  Text file, 9982 bytes
maps:           Text file, 91153 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/kennet4/1

core_backtrace:
:0cb94fee913ddeaaa81390d3e39d4750ae6620b5 0x15a46 e_ews_folder_get_folder_type libeews-1.2.so.0 -
:8498add002a408c0acf1b6762ba7256b2c735a47 0x12f73 ews_utils_sync_folders libcamelews.so -
:8498add002a408c0acf1b6762ba7256b2c735a47 0x1035a - libcamelews.so -
:8498add002a408c0acf1b6762ba7256b2c735a47 0x1086c - libcamelews.so -
:8aae5d2b1beaec6e62bb814ca5893d6e8ac46572 0x990ae camel_service_authenticate_sync libcamel-1.2.so.33 -
:6788832d44a9cfbfc5b009f7e3e27bd94c553c87 0x13ef1 - libemail-engine.so -
:8aae5d2b1beaec6e62bb814ca5893d6e8ac46572 0x9c4ac camel_session_authenticate_sync libcamel-1.2.so.33 -
:8498add002a408c0acf1b6762ba7256b2c735a47 0xfe42 - libcamelews.so -
:8aae5d2b1beaec6e62bb814ca5893d6e8ac46572 0x98db2 camel_service_connect_sync libcamel-1.2.so.33 -
:8498add002a408c0acf1b6762ba7256b2c735a47 0x109ac - libcamelews.so -
:8aae5d2b1beaec6e62bb814ca5893d6e8ac46572 0xa8932 camel_store_get_folder_info_sync libcamel-1.2.so.33 -
:8aae5d2b1beaec6e62bb814ca5893d6e8ac46572 0xa8d19 - libcamel-1.2.so.33 -
:647c8183274c4626c81e86e7a631a81782a04e65 0x6cd2e - libgio-2.0.so.0 -
:647c8183274c4626c81e86e7a631a81782a04e65 0x5c0fe - libgio-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x6ab12 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x6a315 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XSUNTRANSPORT=shmem
:XDG_SESSION_ID=1
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=kennet4
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/home/kennet4/.cache/keyring-hkeJRB
:SYSFONT=True
:MOZILLA_FIVE_HOME=/usr/lib64/firefox
:IMSETTINGS_MODULE=none
:USER=kennet4
:LD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
:LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
:GNOME_DISABLE_CRASH_DIALOG=1
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins:/usr/lib64/firefox/plugins
:DESKTOP_SESSION=LXDE
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/kennet4/.local/bin:/home/kennet4/bin
:MAIL=/var/spool/mail/kennet4
:FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
:QT_IM_MODULE=xim
:PWD=/home/kennet4
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=930
:LANG=en_US.UTF-8
:XSUNSMESIZE=512
:KEYTABLE=us
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:_LXSESSION_PID=997
:XDG_SEAT=seat0
:HOME=/home/kennet4
:SHLVL=1
:XDG_CONFIG_HOME=/home/kennet4/.config
:BOOT_IMAGE=/vmlinuz-3.3.7-1.fc17.x86_64
:DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:LOGNAME=kennet4
:MOZ_GRE_CONF=/etc/gre.d/gre64.conf
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-xLGzo32HM3,guid=f08cd06d71795f983539d6fd0000001a
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:XDG_RUNTIME_DIR=/run/user/kennet4
:DISPLAY=:0
:GTK_IM_MODULE=gtk-im-context-simple
:XDG_CURRENT_DESKTOP=LXDE
:XAUTHORITY=/home/kennet4/.Xauthority
:NO_AT_BRIDGE=1
:MOZ_CRASHREPORTER_RESTART_ARG_0=/usr/lib64/firefox/firefox
:MOZ_CRASHREPORTER_RESTART_ARG_1=
:'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/kennet4/.mozilla/firefox/Crash Reports'
:MOZ_LAUNCHED_CHILD=
:ORBIT_SOCKETDIR=/tmp/orbit-kennet4
:XRE_PROFILE_PATH=
:XRE_PROFILE_LOCAL_PATH=
:XRE_PROFILE_NAME=
:XRE_START_OFFLINE=
:NO_EM_RESTART=
:XUL_APP_FILE=
:XRE_BINARY_PATH=
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=27462

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30403                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30403                30403                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/var/log/lxdm.log
:pos:	1905
:flags:	0102001
:2:/home/kennet4/.xsession-errors
:pos:	8535379
:flags:	0100001
:3:socket:[77127]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[78319]
:pos:	0
:flags:	02004002
:7:socket:[78323]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[76196]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:/home/kennet4/.pki/nssdb/cert9.db
:pos:	2048
:flags:	02100002
:13:/var/tmp/etilqs_IO1D7eZl8VoeWPy (deleted)
:pos:	28
:flags:	02100002
:14:/var/tmp/etilqs_cwBnOPtV8Tw43LF (deleted)
:pos:	2056
:flags:	02500002
:15:/var/tmp/etilqs_Lr98fsoJ9dV1RU9 (deleted)
:pos:	2048
:flags:	02500002
:16:/home/kennet4/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:17:/var/tmp/etilqs_VLu9MTpqcWeX9kR (deleted)
:pos:	28
:flags:	02100002
:18:/var/tmp/etilqs_ocxaZGBkj49BfFi (deleted)
:pos:	2056
:flags:	02500002
:19:/var/tmp/etilqs_wufcrdrQQ55ZdBs (deleted)
:pos:	2048
:flags:	02500002
:20:/etc/pki/nssdb/cert9.db
:pos:	2048
:flags:	02100000
:21:/var/tmp/etilqs_LgNsIY0NVR8XTOs (deleted)
:pos:	28
:flags:	02100002
:22:/var/tmp/etilqs_eRbdma8zLbOGjE7 (deleted)
:pos:	2048
:flags:	02500002
:23:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:24:/var/tmp/etilqs_tL83j9OLRwLHfT3 (deleted)
:pos:	28
:flags:	02100002
:25:/var/tmp/etilqs_yK7ti64lf04JeQo (deleted)
:pos:	2048
:flags:	02500002
:26:socket:[78327]
:pos:	0
:flags:	02004002
:27:/home/kennet4/.local/share/evolution/mail/local/folders.db
:pos:	48128
:flags:	02100002
:28:/home/kennet4/.local/share/evolution/mail/vfolder/folders.db
:pos:	40
:flags:	02100002
:29:/home/kennet4/.cache/evolution/mail/1338484105.22555.21@kennet4.clemson.edu/folders.db
:pos:	40
:flags:	02100002
:30:anon_inode:inotify
:pos:	0
:flags:	02004000
:31:socket:[79154]
:pos:	0
:flags:	02004002
:32:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:33:/dev/urandom
:pos:	0
:flags:	02100000
:34:socket:[76202]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 7d4f6fde-2ff7-42d3-b81f-0e5778362cb3
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6384.46
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU         650  @ 3.20GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 3193
:System Memory: 3819
:System Swap: 5855
:Vendor: Dell Inc.
:System: OptiPlex 980 
:Form factor: Mini Tower
:Kernel: 3.3.7-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:64:4136:730) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:65:4136:730) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(32902:15152:4136:730) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:10274:4136:730) pci, ahci, RAID, 82801 SATA RAID Controller
:(32902:15114:4136:730) pci, None, PCI/ISA, 5 Series Chipset LPC Interface Controller
:(32902:4335:4136:730) pci, e1000e, ETHERNET, 82578DM Gigabit Network Connection
:(32902:9294:4136:730) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:15164:4136:730) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4136:730) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:4136:730) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:15170:4136:730) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15178:4136:730) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:4136:730) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15207:4136:730) pci, serial, 16550_SERIAL, 5 Series/3400 Series Chipset KT Controller
:(32902:15206:4136:730) pci, ata_generic, STORAGE, 5 Series/3400 Series Chipset PT IDER Controller
:(4318:3044:4136:3323) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(4318:3232:4136:3323) pci, nvidia, VIDEO, GT215 [GeForce GT 330]
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11361:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_kennet4-lv_root / ext4 4096 4096 13092922 6726544 6595494 3276800 3165883 3165883
:/dev/sda1 /boot ext4 1024 1024 508745 423936 398336 128016 127660 127660
:/dev/mapper/vg_kennet4-lv_home /home ext4 4096 4096 63332473 61501418 58331114 15851520 15844564 15844564
:

var_log_messages:
:May 31 13:07:45 kennet4 yum[22342]: Installed: evolution-data-server-3.4.1-2.fc17.x86_64
:May 31 13:07:49 kennet4 yum[22342]: Installed: evolution-3.4.1-2.fc17.x86_64
:May 31 13:07:49 kennet4 yum[22342]: Installed: evolution-ews-3.4.1-1.fc17.x86_64
:May 31 13:19:32 kennet4 abrt[23433]: Saved core dump of pid 23422 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-31-13:19:32-23422 (103641088 bytes)
:May 31 13:20:06 kennet4 abrt[23493]: Saved core dump of pid 23482 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-31-13:20:05-23482 (103763968 bytes)
:May 31 13:50:16 kennet4 abrt[25119]: Saved core dump of pid 25103 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-31-13:50:16-25103 (95014912 bytes)
:May 31 15:47:14 kennet4 abrt[1403]: Saved core dump of pid 1365 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-31-15:47:14-1365 (104542208 bytes)
:Jun  1 11:15:36 kennet4 abrt[27349]: Saved core dump of pid 27315 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-01-11:15:35-27315 (119443456 bytes)
:Jun  1 11:16:08 kennet4 abrt[27487]: Saved core dump of pid 27462 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-01-11:16:07-27462 (125095936 bytes)
Comment 1 Kenneth Brown 2012-06-01 11:24:35 EDT
Created attachment 588512 [details]
File: backtrace
Comment 2 Kenneth Brown 2012-06-01 11:24:37 EDT
Created attachment 588513 [details]
File: gconf_subtree
Comment 3 Kenneth Brown 2012-06-01 11:24:39 EDT
Created attachment 588514 [details]
File: maps
Comment 4 Kenneth Brown 2012-06-01 11:24:40 EDT
Created attachment 588515 [details]
File: dso_list
Comment 5 Kenneth Brown 2012-06-01 11:24:42 EDT
Created attachment 588516 [details]
File: build_ids
Comment 6 Kenneth Brown 2012-06-01 11:28:02 EDT
I setup a Microsoft Exchange Server 2007 account in Evolution with the Exchange Web Services plugin. Everything was working correctly. However, the next time I tried to open Evolution(and every time since then), Evolution crashes a few seconds after opening.

My system is up to date, and I've tried rebooting.
Comment 7 Milan Crha 2012-06-04 05:59:01 EDT
Thanks for a bug report. There is a similar bug #787514 filled against Fedora 16, and I suppose this is just about the same issue. It seems to me that this happened when one (or more) folders were removed or renamed on the server, and evolution-ews tries to synchronize this state. I think, if you'll delete your local cache for thw EWS account, then it'll be downloaded from scratch and thus this folder synchronization will not happen again, and evolution will start as expected. The local account cache is stored in
   ~/.cache/evolution/mail/<ews-account-id>/
you can recognize the correct folder also based on the files in the subfolder, where the EWS account has there 'folder-tree' file. You can safely remove the whole folder, because all data are stored on the server and this serves only as a local copy for quicker local operations.

I'm adding your backtrace to the corresponding upstream bug [1] and closing this as a duplicate of the Fedora bug. Please add yourself to [1], if possible, in case upstream developers will have addition questions. Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=669460

*** This bug has been marked as a duplicate of bug 787514 ***
Comment 8 Milan Crha 2012-07-16 12:49:08 EDT
*** Bug 839910 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.