Bug 827492 - missing dependencies in katello-common
missing dependencies in katello-common
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Kedar Bidarkar
: Triaged, ZStream
Depends On: 819941
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 11:36 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Missing qpid-cpp-* packages cause katello-configure to install missing qpid RPMS. This update adds the qpid-cpp-* RPMs as a dependency of the katello-all package and installs them before configuration.
Story Points: ---
Clone Of: 819941
Environment:
Last Closed: 2012-07-10 03:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1062 normal SHIPPED_LIVE CloudForms System Engine 1.0.1 bug fix update 2012-07-10 07:18:51 EDT

  None (edit)
Comment 3 Kedar Bidarkar 2012-06-05 15:37:07 EDT
[root@dhcp201-220 katello]# for i in katello-configure-20120605-211822 katello-configure-20120605-224353 katello-configure-20120605-225146; do echo $i ; grep "yum.*install" /var/log/katello/$i/main.log ; done
katello-configure-20120605-211822
katello-configure-20120605-224353
katello-configure-20120605-225146

--> Processing Dependency: mongodb-server for package: katello-all-0.1.313-1.el6_3.noarch
--> Processing Dependency: mongodb for package: katello-all-0.1.313-1.el6_3.noarch

--> Processing Dependency: mod_authz_ldap for package: katello-common-0.1.313-1.el6_3.noarch

Note: All qpid related packages where pre-installed during os installation on this setup.
Comment 4 Kedar Bidarkar 2012-06-05 15:56:28 EDT
my kickstart had client-mgmt-tools group set(matahari) , which inturn pulled in qpid-cpp packages during os install itself. Next install plan is to avoid client-mgmt-tools to check for qpid-cpp packages.
Comment 5 Kedar Bidarkar 2012-06-06 02:29:32 EDT
I had faced few issues and had re-installed , but this time without the client-mgmt-tools group set.

Processing Dependency: qpid-cpp-server-ssl for package: katello-all-0.1.313-1.el6_3.noarch
--> Processing Dependency: qpid-cpp-server for package: katello-all-0.1.313-1.el6_3.noarch
--> Processing Dependency: qpid-cpp-client-ssl for package: katello-all-0.1.313-1.el6_3.noarch
--> Processing Dependency: qpid-cpp-client for package: katello-all-0.1.313-1.el6_3.noarch

[root@dhcp201-220 katello]# for i in katello-configure-20120606-032840 katello-configure-20120606-114655 katello-configure-20120606-115416
> do
> echo $i ; grep "yum.*install" /var/log/katello/$i/main.log
> done
katello-configure-20120606-032840
katello-configure-20120606-114655
katello-configure-20120606-115416
Comment 6 sachua 2012-06-12 01:14:19 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
User has to rely on katello-configure's puppet manifests to install qpid RPMS. This update will add the qpid RPMs to the katello-all package and user will not have to add these RPMs during katello-configure.
Comment 7 Dan Macpherson 2012-06-13 00:18:04 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-User has to rely on katello-configure's puppet manifests to install qpid RPMS. This update will add the qpid RPMs to the katello-all package and user will not have to add these RPMs during katello-configure.+Missing qpid-cpp-* packages cause katello-configure to install missing qpid RPMS. This update adds the qpid-cpp-* RPMs as a dependency of the katello-all package and installs them before configuration.
Comment 9 errata-xmlrpc 2012-07-10 03:24:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html

Note You need to log in before you can comment on or make changes to this bug.