This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 827495 - Changes to the BPEL process are not deployed automatically after save
Changes to the BPEL process are not deployed automatically after save
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling (Show other bugs)
5.3.0 GA
Unspecified Unspecified
high Severity high
: CR1
: 5.3.0 GA
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 11:42 EDT by Len DiMaggio
Modified: 2012-06-22 03:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If you make a changes to a BPEL process, they will not deploy automatically after saving. This kind of incremental publishing is ignored by BPEL because it results in multiple deployments being triggered at once. Redeploying the process should result in a "full publish".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 09:45:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-9789 None Closed Changes to the BPEL process are not deployed automatically after save. 2012-06-22 03:48:50 EDT

  None (edit)
Description Len DiMaggio 2012-06-01 11:42:36 EDT
Description of problem:

Link to: https://issues.jboss.org/browse/JBIDE-9789

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Suz 2012-06-12 01:24:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If you make a changes to a BPEL process, they will not deploy automatically after saving. This kind of incremental publishing is ignored by BPEL because it results in multiple deployments being triggered at once. Redeploying the process should result in a "full publish".
Comment 3 JBoss JIRA Server 2012-06-21 09:43:23 EDT
Len DiMaggio <ldimaggi@redhat.com> made a comment on jira JBIDE-9789

The consensus with PGM and PM was to: "Leave as is. Documentation is needed to say this is done intentionally. "
Comment 4 JBoss JIRA Server 2012-06-22 03:42:43 EDT
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-9789

Situation in SOA Tooling CR1:
Now, the behaviour is like in JBDS 4. After saving some changes only the status is changed to 'Republish'. The changes take affect after doing 'full publish'.
Comment 5 JBoss JIRA Server 2012-06-22 03:48:50 EDT
Andrej Podhradsky <apodhrad@redhat.com> updated the status of jira JBIDE-9789 to Closed
Comment 6 JBoss JIRA Server 2012-06-22 03:48:50 EDT
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-9789

We can close this issue as it has been resolved. But note that status should be fixed (JBIDE-11928).

Note You need to log in before you can comment on or make changes to this bug.