Bug 827497 - filelight missing versioned kdelibs4 dependency
filelight missing versioned kdelibs4 dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: filelight (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neal Becker
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 11:46 EDT by Neal Becker
Modified: 2012-06-05 09:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 09:18:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2012-06-01 11:46:34 EDT
Description of problem:
Just tried

filelight-4.8.80-1.fc18.x86_64 

on my f17 x86_64 system.  It doesn't work.  Get message about error with filelight_part (or something like that).

Downgrade to 
filelight-4.8.3-1.fc17.x86_64  
fixed it

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2012-06-01 11:48:56 EDT
You cannot use KParts built against a newer kdelibs on an older kdelibs.
Comment 2 Jaroslav Reznik 2012-06-04 07:34:19 EDT
Wait for proper F17 builds (coming soon, there was some mess going on, so we are a little bit delayed). I'm going to close this bug a NOTABUG.
Comment 3 Kevin Kofler 2012-06-04 09:30:07 EDT
There's a genuine bug in the filelight specfile:
%{?_kde4:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
should be:
%{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}

That makes the versioned Requires not work and thus allowed installing filelight without the proper kdelibs.
Comment 4 Rex Dieter 2012-06-05 09:18:38 EDT
Looks like I did that as a bad attempt to save a little typing, except that %{_kde4} doesn't actually exist or work. :-/

Anyway, it's all fixed up in rawhide and will get rolled into 4.8.4 packaging coming real soon.


However, i've seen similar kpart problems as described here on occasion, even with the requisite kdelibs installed.  May be some other sort of bug, but manually running:
kbuildsycoca4 --noincremental
solved it.

Note You need to log in before you can comment on or make changes to this bug.