Bug 827563 - Pulseaudio segmentation fault when enabling bluetooth audio
Pulseaudio segmentation fault when enabling bluetooth audio
Status: CLOSED DUPLICATE of bug 827629
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 14:54 EDT by Alex Markley
Modified: 2012-06-18 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 15:41:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System log of pulseaudio and bluetooth messages. Shows startup, some volume adjustment, and crash. (38.84 KB, text/plain)
2012-06-01 14:54 EDT, Alex Markley
no flags Details

  None (edit)
Description Alex Markley 2012-06-01 14:54:19 EDT
Created attachment 588561 [details]
System log of pulseaudio and bluetooth messages. Shows startup, some volume adjustment, and crash.

Description of problem:

Pulseaudio crashes when enabling a bluetooth headset.

Version-Release number of selected component (if applicable): 

alsa-plugins-pulseaudio-1.0.25-3.fc17.i686
blueman-1.23-2.fc17.i686
bluez-4.99-1.fc17.i686
bluez-alsa-4.99-1.fc17.i686
bluez-compat-4.99-1.fc17.i686
bluez-cups-4.99-1.fc17.i686
bluez-debuginfo-4.99-1.fc17.i686
bluez-gstreamer-4.99-1.fc17.i686
bluez-hcidump-2.2-2.fc17.i686
bluez-hcidump-debuginfo-2.2-2.fc17.i686
bluez-libs-4.99-1.fc17.i686
bluez-libs-devel-4.99-1.fc17.i686
gnome-bluetooth-3.4.0-2.fc17.i686
gnome-bluetooth-libs-3.4.0-2.fc17.i686
pulseaudio-1.1-9.fc17.i686
pulseaudio-gdm-hooks-1.1-9.fc17.i686
pulseaudio-libs-1.1-9.fc17.i686
pulseaudio-libs-glib2-1.1-9.fc17.i686
pulseaudio-module-bluetooth-1.1-9.fc17.i686
pulseaudio-module-gconf-1.1-9.fc17.i686
pulseaudio-module-x11-1.1-9.fc17.i686
pulseaudio-utils-1.1-9.fc17.i686
wine-pulseaudio-1.5.3-1.fc17.i686

How reproducible:

Completely reproducible. Segfaults every time.

Steps to Reproduce:

1. Fresh session, observe sound services working properly using built-in sound hardware.
2. Use gnome bluetooth tools to pair / connect to paired headphones.
3. Sound-related services are gone. Observe segfault message in logs.
  
Actual results:

kernel: [  171.585363] pulseaudio[1888]: segfault at 9000000 ip 42d70ad6 sp bf9ace44 error 4 in libc-2.15.so[42cee000+1a8000]

Expected results:

Beautiful music in my headphones. :)

Additional info:

- Same hardware was working fine in Fedora 16.
- I enabled debug logging in pulseaudio, then I grabbed a log snapshot of the issue. (Attached.)
Comment 1 Brendan Jones 2012-06-15 05:43:31 EDT
Can you try the workaround suggested here: https://bugzilla.redhat.com/show_bug.cgi?id=827629#c14
Comment 2 Alex Markley 2012-06-17 11:22:04 EDT
Brendan, thanks so much for pointing this out! I have tried the workaround and it helped me. I have posted a comment on bug #827629 to confirm: https://bugzilla.redhat.com/show_bug.cgi?id=827629#c19

I noticed that other reporters of this bug are using 32 bit (i686) systems as well. For myself, I have two Fedora 17 systems, one x86_64 and one i686. Only the i686 system has been running into this issue.
Comment 3 Brendan Jones 2012-06-18 15:41:29 EDT
Good news!

*** This bug has been marked as a duplicate of bug 827629 ***

Note You need to log in before you can comment on or make changes to this bug.