Bug 827567 - VNC install fails
VNC install fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 15:03 EDT by Scott Baker
Modified: 2013-01-10 01:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 19:56:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of error (68.67 KB, image/jpeg)
2012-06-01 15:03 EDT, Scott Baker
no flags Details

  None (edit)
Description Scott Baker 2012-06-01 15:03:06 EDT
Created attachment 588562 [details]
Screen shot of error

Description of problem:
VNC installs fails with a Python error

How reproducible: Easy

Steps to Reproduce:
1. Insert the x86_64 DVD 
2. Get to the install prompt
3. Hit esc
4. Type "linux vnc"
  
Actual results:
Fails with a Python error: "AttributeError: 'NoneType' object has no attribute 'find'"

I think it's referring to the IP address. I never entered an IP address, and anaconda didn't ask me for one. Previous versions asked for an IP before starting VNC.

Expected results:
VNC starts and I can install
Comment 1 Scott Baker 2012-06-01 16:26:51 EDT
This may be because I don't have a DHCP server on that network. If I try it in a virtual machine that has a DHCP server it appears to work. 

Anaconda used to ask for IP information if you specified VNC install and didn't supply IP information at the command line. That worked well, please bring that back.
Comment 2 Jesse Keating 2012-06-28 20:09:56 EDT
We've removed all the code that would prompt for that prior to running anaconda. It's not coming back.  There are boot options to specify the IP address http://fedoraproject.org/wiki/Dracut/Options#Network

I have posted code that will exit the installer if no IP is found, but it will do it cleanly, not with a traceback.
Comment 3 Jesse Keating 2012-06-29 17:08:15 EDT
Pushed as 167a0e193969b9ce531684637eaf7e89e35bad69 and 29f4ed3f2b83fad2a1209105819b4b67f61fb194

Will be fixed in the next build of anaconda (for rawhide).
Comment 4 Jesse Keating 2012-10-03 19:56:28 EDT
This is fixed in branched.

Note You need to log in before you can comment on or make changes to this bug.