Bug 827653 - Gallery3 showing blank page
Gallery3 showing blank page
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gallery3 (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 23:04 EDT by Yogesh Sharma
Modified: 2013-08-01 13:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 13:43:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yogesh Sharma 2012-06-01 23:04:24 EDT
Description of problem:
Gallery3 is showing blankpage since upgrade to fedora17.
Fedora16 was working fine.

Version-Release number of selected component (if applicable):
3.0.3

How reproducible:
always

Steps to Reproduce:
1.Upgrade to FC17
2.
3.
  
created local.php as suggeted at upstream

var/log/
<?php defined('SYSPATH') or die('No direct script access.'); ?>

2012-06-01 19:58:35 -07:00 --- error: Kohana_Exception [ 403 ]: @todo FORBIDDEN
/home/server/vhosts/album.catprosystems.com/modules/gallery/helpers/access.php [ 202 ]
#0 /usr/share/gallery3/modules/gallery/helpers/access.php(425): access_Core::forbidden()
#1 /usr/share/gallery3/modules/gallery/controllers/quick.php(61): access_Core::verify_csrf()
#2 [internal function]: Quick_Controller->make_album_cover('46')
#3 /usr/share/php/Kohana/system/core/Kohana.php(303): ReflectionMethod->invokeArgs(Object(Quick_Controller), Array)
#4 [internal function]: Kohana_Core::instance(NULL)
#5 /usr/share/gallery3/system/core/Event.php(208): call_user_func_array(Array, Array)
#6 /usr/share/gallery3/application/Bootstrap.php(67): Event_Core::run('system.execute')
#7 /usr/share/gallery3/index.php(102): require('/home/server/vh...')
#8 {main}
2012-06-01 19:58:35 -07:00 --- error: Missing messages entry core.errors.403 for message core
Comment 1 Gwyn Ciesla 2012-06-11 10:29:55 EDT
Part of you issues is likely SELinux preventing Apache from reading from /home, which is as it should be, but I can't get gallery3 to work at all.
Comment 2 Knut J BJuland 2012-07-09 14:41:00 EDT
Hi I got a similar error with gallery3 installation. However, I have stopped selinux.
Comment 3 Yogesh Sharma 2012-07-10 00:50:20 EDT
I upgraded to latest release (3.0.4) and it started working.
My Selinux was already disabled.
Comment 4 Knut J BJuland 2012-07-10 02:22:11 EDT
I have upgrade to 3.04 but I have also upgrade to rpm from updates-testing. I get this error and blank page when point the browser to ip_adresse/gallery3.
<?php defined('SYSPATH') or die('No direct script access.'); ?>
Comment 5 Yogesh Sharma 2012-07-17 23:42:56 EDT
Problem came back as soon as I rebooted system. Now I get blank page again.
Comment 6 Yogesh Sharma 2012-08-03 08:18:52 EDT
At the end following made it work:
1) Backup images
2) Backup database
3) Drop database
4) Remove old install
5) Install Fresh
6) Create database
7) Run Gallery3 installer
8) Enable server side album add module
9) Re-add all images from back

Basically started from scratch
Comment 7 Robert Hoekstra 2013-01-03 04:14:22 EST
I seem to hit the same issue and seem to be unable to get any workaround to work.

What I have is an upgraded system from fc16 to fc17. I have cleaned out all RPMS that were either orphaned or still fc16, so the software installed is all from fc17.

SELinux is (still) in permissive mode to prevent breakage until all is fine.

I have created a fresh new install on a new database, a clean var directory, ie I ran the installer to create a new storage location with a new database. Still the blank page.

I tried with and without memcached and found that WITH memcached the site showed at least SOMETHING, but only when I:

1) disable the register_shutdown_function call in Kohana.php
2) grow the memory_limit to like 2560M

But, also with the fresh installed edition of Galley3 I manage to get like one or two pages before the apache log shows segfaults.

with register_shutdown_function ON I don't see ANYTHING in the logs nor in the browser.
Comment 8 Fedora End Of Life 2013-07-04 02:13:19 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 13:43:34 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.