Bug 827659 - try sudo yum -y --skip-broken update
try sudo yum -y --skip-broken update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 01:44 EDT by Chen_Min_Chin
Modified: 2014-01-21 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 15:25:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chen_Min_Chin 2012-06-02 01:44:39 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Use fedora17 DVD update sysytem from fedora16 to fedora17.
2.Update system complete.
3.Use terminal to execute "sudo yum -y --skip-broken update"

  
Actual results:

[tcfxfzoi@localhost ~]$ sudo yum -y --skip-broken update
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package gsoap.x86_64 0:2.8.3-2.fc16 will be updated
--> Processing Dependency: libgsoapssl++.so.0()(64bit) for package: VirtualBox-4.1.16-2.fc16.x86_64
---> Package gsoap.x86_64 0:2.8.7-2.fc17 will be an update
---> Package llvm-libs.i686 0:2.9-10.fc16 will be updated
---> Package llvm-libs.x86_64 0:3.0-12.fc17 will be updated
---> Package llvm-libs.i686 0:3.0-13.fc17 will be an update
---> Package llvm-libs.x86_64 0:3.0-13.fc17 will be an update
---> Package mesa-dri-drivers.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-dri-drivers.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-drivers.i686 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-drivers.x86_64 0:8.0.3-1.fc17 will be an update
--> Running transaction check
---> Package gsoap.x86_64 0:2.8.3-2.fc16 will be updated
---> Package gsoap.x86_64 0:2.8.7-2.fc17 will be an update
--> Running transaction check
---> Package llvm-libs.i686 0:2.9-10.fc16 will be updated
---> Package llvm-libs.x86_64 0:3.0-12.fc17 will be updated
---> Package llvm-libs.i686 0:3.0-13.fc17 will be an update
---> Package llvm-libs.x86_64 0:3.0-13.fc17 will be an update
---> Package mesa-dri-drivers.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-dri-drivers.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-drivers.i686 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-drivers.x86_64 0:8.0.3-1.fc17 will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    gsoap-2.8.7-2.fc17.x86_64 from fedora

Dependencies Resolved

================================================================================
 Package                 Arch          Version             Repository      Size
================================================================================
Updating:
 llvm-libs               i686          3.0-13.fc17         updates        6.1 M
 llvm-libs               x86_64        3.0-13.fc17         updates        5.9 M
 mesa-dri-drivers        i686          8.0.3-1.fc17        updates         12 M
 mesa-dri-drivers        x86_64        8.0.3-1.fc17        updates         11 M
Skipped (dependency problems):
 gsoap                   x86_64        2.8.7-2.fc17        fedora         218 k

Transaction Summary
================================================================================
Upgrade                        4 Packages
Skipped (dependency problems)  1 Package

Total size: 35 M
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
llvm-libs-3.0-12.fc17.x86_64 is a duplicate with llvm-libs-2.9-10.fc16.i686
mesa-dri-drivers-7.11.2-3.fc16.i686 has missing requires of mesa-dri-filesystem(x86-32)
mesa-dri-drivers-8.0.2-8.fc17.x86_64 is a duplicate with mesa-dri-drivers-7.11.2-3.fc16.i686
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-06-02.13-27.2LZBK9.yumtx
[tcfxfzoi@localhost ~]$ 

Expected results:

It should upadte successfully.


Additional info:
Comment 1 James Antill 2013-05-21 15:25:29 EDT
 As it says, it's hitting a preexisting problem.

Note You need to log in before you can comment on or make changes to this bug.