Bug 827679 - SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' accesses on the directory #SharedObjects.
SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' acc...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6a52651461ec1a7f1f1cd0fef5c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 04:43 EDT by Orion Caspar
Modified: 2012-06-04 10:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 10:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Caspar 2012-06-02 04:43:37 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.i686.PAE
time:           Sat 02 Jun 2012 02:11:29 PM IST

description:
:SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' accesses on the directory #SharedObjects.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed create access on the #SharedObjects directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                #SharedObjects [ dir ]
:Source                        plugin-containe
:Source Path                   /usr/lib/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-12.0-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.i686.PAE #1 SMP
:                              Mon May 21 22:42:05 UTC 2012 i686 i686
:Alert Count                   33
:First Seen                    Sat 02 Jun 2012 12:53:48 PM IST
:Last Seen                     Sat 02 Jun 2012 12:58:19 PM IST
:Local ID                      b7b8b0e9-9d81-4d54-a0b0-7bb165623379
:
:Raw Audit Messages
:type=AVC msg=audit(1338622099.27:275): avc:  denied  { create } for  pid=1616 comm="plugin-containe" name="#SharedObjects" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1338622099.27:275): arch=i386 syscall=mkdir success=no exit=EACCES a0=af830560 a1=1c0 a2=b4882688 a3=af830560 items=0 ppid=1552 pid=1616 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,admin_home_t,dir,create
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t admin_home_t:dir create;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t admin_home_t:dir create;
:
Comment 1 Miroslav Grepl 2012-06-04 10:14:33 EDT
Do you know what you were doing when this happened?
Comment 2 Daniel Walsh 2012-06-04 10:42:42 EDT
This looks like you are running firefox as root, which is not a good idea and not something that selinux will support.

You have to run in permissive mode and ignore the AVC's if you want to run firefox.  But this is very dangerous.

Note You need to log in before you can comment on or make changes to this bug.