Bug 827684 - SELinux is preventing /usr/lib/systemd/systemd-udevd (deleted) from 'associate' accesses on the filesystem lp0.
SELinux is preventing /usr/lib/systemd/systemd-udevd (deleted) from 'associat...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0f40165e7e06a5fd88feb70c60b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 05:18 EDT by Nicolas Mailhot
Modified: 2012-06-04 16:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 16:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-02 05:18:53 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-2.fc18.x86_64
time:           sam. 02 juin 2012 11:12:16 CEST

description:
:SELinux is preventing /usr/lib/systemd/systemd-udevd (deleted) from 'associate' accesses on the filesystem lp0.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-udevd (deleted) should be allowed associate access on the lp0 filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-udevd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:object_r:default_t:s0
:Target Context                system_u:object_r:device_t:s0
:Target Objects                lp0 [ filesystem ]
:Source                        systemd-udevd
:Source Path                   /usr/lib/systemd/systemd-udevd (deleted)
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           systemd-184-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-127.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-2.fc18.x86_64 #1 SMP Mon May
:                              21 21:18:35 UTC 2012 x86_64 x86_64
:Alert Count                   367
:First Seen                    ven. 01 juin 2012 07:26:26 CEST
:Last Seen                     sam. 02 juin 2012 11:11:16 CEST
:Local ID                      7a90d7a1-4378-487f-adba-b9e2f54a9f74
:
:Raw Audit Messages
:type=AVC msg=audit(1338628276.231:1172): avc:  denied  { associate } for  pid=6670 comm="systemd-udevd" name="lp0" dev="devtmpfs" ino=312904 scontext=system_u:object_r:default_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=filesystem
:
:
:type=SYSCALL msg=audit(1338628276.231:1172): arch=x86_64 syscall=lsetxattr success=yes exit=0 a0=1434fe0 a1=3634c16b7b a2=14376c0 a3=1f items=0 ppid=420 pid=6670 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-udevd exe=/usr/lib/systemd/systemd-udevd subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: systemd-udevd,default_t,device_t,filesystem,associate
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-06-04 16:00:40 EDT
Duplicate of 828375

Note You need to log in before you can comment on or make changes to this bug.