Bug 827686 - Freshly updated F17 (from F16 via preupgrade) fails with "yum update -y"
Freshly updated F17 (from F16 via preupgrade) fails with "yum update -y"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 05:55 EDT by Harish Pillay
Modified: 2014-01-21 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 16:33:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harish Pillay 2012-06-02 05:55:47 EDT
Description of problem:
My Acer Aspire One netbook was updated from Fedora 16 to Fedora 17 via preupgrade. Before preupgrade, the system was fully updated. 

Once preupgrade ended, the system booted up fine, but the kernel it is running shows it to be 3.3.7-1.fc16.i686 instead of fc17. So, I tried to run "yum update -y".  That bombs out with the following error:

"Error: requested datatype primary not available" 

Version-Release number of selected component (if applicable):
Yum version 3.4.3

How reproducible:

everytime I run "yum update -y" that error occurs and nothing gets updated.

Steps to Reproduce:
1. f16 -> f17 via preupgrade
2. reboot and do the install
3. reboot and run "yum update -y"
  
Expected results:

Yum should have updated whatever that needs to be updated.  I'd done yum clean ll, rm'ed the *.db files and nothing seems to help.

Additional info:

none for now.
Comment 1 James Antill 2013-05-28 16:33:19 EDT
> "Error: requested datatype primary not available" 

 This seems like yum is saying that it's downloaded a repomd.xml for one of the repos. you've specified but it contains invalid data (it doesn't contain a primary, which is required).

Note You need to log in before you can comment on or make changes to this bug.