Bug 827689 - dvb kernel modules wrong load order - A frontend driver was not found for device
dvb kernel modules wrong load order - A frontend driver was not found for device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 06:21 EDT by MartinKG
Modified: 2014-03-16 23:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-09 13:33:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (117.77 KB, text/plain)
2012-06-03 09:37 EDT, MartinKG
no flags Details

  None (edit)
Description MartinKG 2012-06-02 06:21:05 EDT
Description of problem:
after updating my fedora 16 to fedora 17, my 


Version-Release number of selected component (if applicable):
Linux fc17 3.3.7-1.fc17.x86_64

# modinfo dvb_ttpci
filename:       /lib/modules/3.3.7-1.fc17.x86_64/kernel/drivers/media/dvb/ttpci/dvb-ttpci.ko
firmware:       av7110/bootcode.bin
license:        GPL
author:         Ralph Metzler, Marcus Metzler, others
description:    driver for the SAA7146 based AV110 PCI DVB cards by Siemens, Technotrend, Hauppauge
alias:          pci:v00001131d00007146sv000013C2sd00001002bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd0000000Ebc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd0000000Abc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000008bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000006bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000004bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000003bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000002bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000001bc*sc*i*
alias:          pci:v00001131d00007146sv000013C2sd00000000bc*sc*i*
alias:          pci:v00001131d00007146sv0000110Asd00000000bc*sc*i*
depends:        dvb-core,saa7146,i2c-core,saa7146_vv,ttpci-eeprom
intree:         Y
vermagic:       3.3.7-1.fc17.x86_64 SMP mod_unload 
parm:           ir_protocol:Infrared protocol: 0 RC5, 1 RCMM (default) (array of int)
parm:           ir_inversion:Inversion of infrared signal: 0 not inverted (default), 1 inverted (array of int)
parm:           ir_device_mask:Bitmask of infrared devices: bit 0..31 = device 0..31 (default: all) (array of uint)
parm:           debug:debug level (bitmask, default 0) (int)
parm:           vidmode:analog video out: 0 off, 1 CVBS+RGB (default), 2 CVBS+YC, 3 YC (int)
parm:           pids_off:clear video/audio/PCR PID filters when demux is closed (int)
parm:           adac:audio DAC type: 0 TI, 1 CRYSTAL, 2 MSP (use if autodetection fails) (int)
parm:           hw_sections:0 use software section filter, 1 use hardware (int)
parm:           rgb_on:For Siemens DVB-C cards only: Enable RGB control signal on SCART pin 16 to switch SCART video mode from CVBS to RGB (int)
parm:           volume:initial volume: default 255 (range 0-255) (int)
parm:           budgetpatch:use budget-patch hardware modification: default 0 (0 no, 1 autodetect, 2 always) (int)
parm:           full_ts:enable code for full-ts hardware modification: 0 disable (default), 1 enable (int)
parm:           wss_cfg_4_3:WSS 4:3 - default 0x4008 - bit 15: disable, 14: burst mode, 13..0: wss data (int)
parm:           wss_cfg_16_9:WSS 16:9 - default 0x0007 - bit 15: disable, 14: burst mode, 13..0: wss data (int)
parm:           tv_standard:TV standard: 0 PAL (default), 1 NTSC (int)
parm:           adapter_nr:DVB adapter numbers (array of short)

How reproducible:
update to Fedora 17 

  
Actual results:
dmesg info after boot

[	7.531323] saa7146: register extension 'av7110'
[	7.531389] saa7146: found saa7146 @ mem ffffc90000c7ec00 (revision 1, irq 22) (0x13c2,0x0003)
[	7.540267] leds_ss4200: no LED devices found
[	8.180152] hda_intel: msi for device 1043:81f6 set to 0
[	8.480467] nvidia: module license 'NVIDIA' taints kernel.
[	8.480470] Disabling lock debugging due to kernel taint
[	8.500346] vgaarb: device changed decodes: PCI:0000:06:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[	8.500453] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  295.53  Fri May 11 23:28:10 PDT 2012
[	8.796555] hda_intel: Disabling MSI
[	8.808266] ALSA sound/pci/hda/hda_intel.c:1536 Enable delay in RIRB handling
[	9.239061] HDMI status: Codec=0 Pin=5 Presence_Detect=0 ELD_Valid=0
[	9.248025] HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
[	9.257044] HDMI status: Codec=2 Pin=5 Presence_Detect=0 ELD_Valid=0
[	9.266039] HDMI status: Codec=3 Pin=5 Presence_Detect=0 ELD_Valid=0
[	9.266154] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/0000:06:00.1/sound/card1/input5
[	9.266270] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/0000:06:00.1/sound/card1/input6
[	9.267073] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/0000:06:00.1/sound/card1/input7
[	9.267135] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/0000:06:00.1/sound/card1/input8
[	9.644443] Adding 8388604k swap on /dev/sdb2.  Priority:0 extents:1 across:8388604k 
[	9.908714] fuse init (API version 7.18)
[   37.590330] DVB: registering new adapter (Technotrend/Hauppauge WinTV Nexus-S rev2.X)
[   37.652010] Couldn't read from EEPROM: not there?
[   38.025092] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80fe2624
[   38.025095] dvb-ttpci: firmware @ card 0 supports CI link layer interface
[   38.382012] dvb-ttpci: adac type set to 0 @ card 0
[   38.384094] saa7146_vv: saa7146 (0): registered device video0 [v4l2]
[   38.384479] saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
[   39.094013] ves1820: ves1820_readreg(): readreg error (reg == 0x1a, ret == -512)
[   39.094018] dvb-ttpci: A frontend driver was not found for device [1131:7146] subsystem [13c2:0003]

Expected results:
that the correct load order of dvb modules for Technotrend/Hauppauge WinTV Nexus-S rev2.X


Additional info:

lsmod | grep dvb
dvb_ttpci         	112857  0 
ttpci_eeprom       	12665  1 dvb_ttpci
saa7146_vv         	70335  1 dvb_ttpci
saa7146            	28927  2 saa7146_vv,dvb_ttpci
dvb_core          	107785  2 dvb_ttpci,stv0299
i2c_core           	38028  9 i2c_i801,videodev,ttpci_eeprom,dvb_ttpci,nvidia,ves1x93,stv0299,tda8083,ves1820

Workaround:
# rmmod dvb_ttpci stv0299 dvb_core
# modprobe dvb-ttpci

# dmesg

[   31.351632] Linux video capture interface: v2.00
[   31.361270] saa7146: register extension 'av7110'
[   31.361346] saa7146: found saa7146 @ mem ffffc900057aec00 (revision 1, irq 22) (0x13c2,0x0003)
[   31.362667] DVB: registering new adapter (Technotrend/Hauppauge WinTV Nexus-S rev2.X)
[   31.381064] adapter has MAC addr = 00:d0:5c:21:3f:ee
[   31.709151] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80fb2624
[   31.709156] dvb-ttpci: firmware @ card 0 supports CI link layer interface
[   31.722172] dvb-ttpci: Crystal audio DAC @ card 0 detected
[   31.723017] saa7146_vv: saa7146 (0): registered device video0 [v4l2]
[   31.723073] saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
[   31.957218] DVB: registering adapter 0 frontend 0 (ST STV0299 DVB-S)...
[   31.957381] input: DVB on-card IR receiver as /devices/pci0000:00/0000:00:1e.0/0000:01:01.0/input/input9
[   31.958099] dvb-ttpci: found av7110-0.


# lsmod |grep dvb
dvb_ttpci         	112857  0
dvb_core          	107785  2 dvb_ttpci,stv0299
ttpci_eeprom       	12665  1 dvb_ttpci
saa7146_vv         	70335  1 dvb_ttpci
saa7146            	28927  2 saa7146_vv,dvb_ttpci
i2c_core           	38028  10 videodev,i2c_i801,ttpci_eeprom,dvb_ttpci,nvidia,tda10086,ves1x93,tda8083,ves1820,stv0299
Comment 1 MartinKG 2012-06-03 09:37:36 EDT
Created attachment 588856 [details]
/var/log/messages

Note You need to log in before you can comment on or make changes to this bug.