Bug 827696 - trytond 2.2.2's sysvinit script does not integrate with systemd
trytond 2.2.2's sysvinit script does not integrate with systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: trytond (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 07:31 EDT by Michel Alexandre Salim
Modified: 2012-06-25 20:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:29:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trytond service descriptor for systemd (1.00 KB, application/octet-stream)
2012-06-03 04:26 EDT, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2012-06-02 07:31:31 EDT
Description of problem:
When launching trytond using either 'service trytond start' or 'systemctl start trytond.service', systemctl would stall for a long time and then quit with an error.

trytond itself has actually started successfully, but it seems this failed to be noticed by systemd. Further attempt to query the service reports that the service failed to start due to a timeout.

Version-Release number of selected component (if applicable):
trytond-2.2.2-1.fc17.noarch
systemd-44-12.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install trytond
2. create tryton role in PostgreSQL, adjust /etc/trytond.conf
3. systemctl start trytond.service
  
Actual results:
$ sudo systemctl reload postgresql.service
Job failed. See system journal and 'systemctl status' for details.
$ echo $?
1
$ systemctl status trytond.service
trytond.service - LSB: start and stop trytond
	  Loaded: loaded (/etc/rc.d/init.d/trytond)
	  Active: failed (Result: timeout) since Sat, 02 Jun 2012 18:21:32 +0700; 8min ago
	 Process: 9100 ExecStart=/etc/rc.d/init.d/trytond start (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/trytond.service
		  └ 7486 /usr/bin/python /usr/bin/trytond --config /etc/try...



Expected results:
The "systemctl start" should return immediately upon the service starting

Additional info:
Does this bug occur on RHEL (i.e. is this only a problem when the init system is systemd)? In which case it might be worth writing a systemd service descriptor and using the initscript only on RHEL
Comment 1 Dan Horák 2012-06-02 08:18:53 EDT
If you could prepare the unit file for tryton it would speed up things. But it's the plan to switch to native systemd support.
Comment 2 Michel Alexandre Salim 2012-06-02 11:20:09 EDT
Sure thing; I'll try and find time for it tomorrow
Comment 3 Michel Alexandre Salim 2012-06-03 04:26:23 EDT
Created attachment 588802 [details]
trytond service descriptor for systemd

Adapted from mysqld.service -- note: trytond does not start properly if PrivateTmp is set to true (as mysqld's is)

Tried killing the service and it does get restarted automatically.
Comment 4 Fedora Update System 2012-06-13 05:53:15 EDT
trytond-2.2.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/trytond-2.2.3-2.fc17
Comment 5 Fedora Update System 2012-06-14 20:35:43 EDT
Package trytond-2.2.3-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing trytond-2.2.3-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9441/trytond-2.2.3-2.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-25 20:29:29 EDT
trytond-2.2.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.